Support » Plugin: WP Super Cache » I thought gzip was enabled but test says not

  • Resolved benorange

    (@benorange)


    Hi all,

    I am looking for help with enabling gzip compression with WP Supercache. Thanks in advance.

    Can anyone recommend what else I can try to make WP Supercache enable gzip compression on my site?

    These are the steps I have followed so far..

    Selected “Compress pages so they’re served more quickly to visitors. (Recommended)” in advanced plugin settings.

    Then tested with: https://base64.guru/tools/gzip-test

    Which said: “Gzip is disabled and this is bad because text data should be compressed.”

    So I then backed up the site, spoke to Hostgator to confirm that they support Gzip and run linux, not NGINX or IIS. They did confirm.

    Then I added following code to .htaccess between # BEGIN WordPress and # END WordPress tags:

    # Compress HTML, CSS, JavaScript, Text, XML and fonts
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
    AddOutputFilterByType DEFLATE application/x-font
    AddOutputFilterByType DEFLATE application/x-font-opentype
    AddOutputFilterByType DEFLATE application/x-font-otf
    AddOutputFilterByType DEFLATE application/x-font-truetype
    AddOutputFilterByType DEFLATE application/x-font-ttf
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE font/opentype
    AddOutputFilterByType DEFLATE font/otf
    AddOutputFilterByType DEFLATE font/ttf
    AddOutputFilterByType DEFLATE image/svg+xml
    AddOutputFilterByType DEFLATE image/x-icon
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/javascript
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/xml
    
    # Remove browser bugs (only needed for really old browsers)
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4.0[678] no-gzip
    BrowserMatch bMSIE !no-gzip !gzip-only-text/html
    Header append Vary User-Agent

    This did not change the test result, still showing disabled.

    I then looked at how to manually compress each file on the server but I’m not a fan of this plan as there are regular updates to site, so want to check with this forum what is recommended for supercache users who find this issue.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘I thought gzip was enabled but test says not’ is closed to new replies.