Support » Plugin: User Posts Limit » I think week, month and year are not working during cycle setting.

  • Resolved taxlawmen

    (@taxlawmen1)


    Hi,
    I have a question.
    I think day, week, month and year are not working during cycle setting.
    Can you check this?
    For your information, I tested the guest-written post using the wp user frontend plugin.
    Thank you.

    • This topic was modified 8 months ago by taxlawmen.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Condless

    (@condless)

    Hi,
    Thanks for getting in touch!
    Did you set posts limit on the ‘subscriber’ role?
    Please enable the ‘Document Statistics’ option (via plugin settings) and check the users list (Dashboard => Users), It will help you to find out which limit is applied on which user, you may try none/year/month/week/day cycle values (via plugin settings) to verify the count.
    Keep in mind it counts also posts in the trash, and does not count the first guest-written post of new users since those posts will be assigned to the user configured in Dashboard => User Frontend => Settings => Frontend Posting => Default Post Owner.

    • This reply was modified 8 months ago by Condless.
    Thread Starter taxlawmen

    (@taxlawmen1)

    Thank you for your reply.
    However, I am still having problems.
    And I’ll tell you specifically what the problem is.
    In conclusion, instead of counting each individual role, check the limit by adding up the counters on all posts. This happens all the same when the cycle setting is day, week, month, and year.

    It’s a situation.
    1. user A – 1/3 (= role:subscriber, limit set:3, cycle set:week, post count:1)
    2. user B – 4/7 (= role:customer, limit set:7, cycle set:week, post count:4)
    3. user C – 3/10 (= role:editor, limit set:10, cycle set:week, post count:3)

    It’s a description.
    1. Based on the setting, user A can publish two posts and user B three posts. However, it is not written. The reason is that the sum(8) of all posts with cycle setting as week has already exceeded the limit.

    2. User C can publish a post because the sum of the posts with all cycle settings in week is 8. However, there are only two that can be published. Because the sum of all posts became 10 which is a limit.

    3. Then, in Description1, how should user A set the limit to publish the post? The answer is 9. User A can now publish 1 post. Only one. The limit must be +1 again to publish two posts.

    I tested it all day, week, month and year. The results are the same.
    After all, this determines the limit by adding up the number of posts for all roles if I set the same cycle(day, week, month, year) in each role.

    I want you to check this.
    For your information, I used the wp user frontend plugin, do not allow guest submission, and set up only specific roles(subscriber, customer, editor).

    I hope you can understand this content. The reason is that English is not my language.
    Thank you.

    Plugin Author Condless

    (@condless)

    Hi, thank you for the description,
    If it’s Custom Post Type and not regular post, adding support for the ‘author’ feature may fix the problem.
    Does the problem exist only when same cycle is set for all the rules? what if ‘none’ is selected?
    Can you temproraly switch the website to English and try again?
    Can you apply those rules on stronger roles (‘author’, ‘editor’, ‘adminsitrator’) and try to post from the backend?

    Thread Starter taxlawmen

    (@taxlawmen1)

    Hi,
    I checked what you mentioned and let you know the result.

    1. I didn’t set CPT. I used a normal post.

    2. I retested with ‘none’ setting. In this case, I checked to add up the count, including the post of admin.

    For example,
    1) user A – 1/3 (= role:subscriber, limit set:3, cycle set:none, post count:1)
    2) user B – 4/7 (= role:customer, limit set:7, cycle set:none, post count:4)
    3) admin – 2 (post count:2)

    UserB cannot publish the post. Because the total number of posts published is 7(=1+4+2). How should user B set the limit to public the post? The answer is 8. User B can now publish 1 post. Only one.

    3. I tested it by changing the website settings to English. The results are the same.

    4. I tested it by setting it to a different role(author, contributor). In this case, it has been published. However, counting disappeared from the users list (Dashboard => Users).
    I guess it’s because the counting is not shown for roles like admin, author, and contributor. That is to say, it’s because it’s excluded from the count.
    However, if the cycle setting is set to ‘none’, this role also has the same problem as number 2 above.

    Thank you.

    Plugin Author Condless

    (@condless)

    Can you try the following configuration:
    Rule 1: ‘Author’, ‘Posts’, 2, ‘none’.
    Rule 2: ‘Editor’, ‘Posts’, 3, ‘year’.

    User A: ‘Author’, has 1 post.
    User B: ‘Editor’, has 2 posts.

    Log-in with each user and check if your are able to post via the frontend form and via the backend (Dashboard => Posts => Add new).
    Than, change Rule 2 cycle into ‘none’, and try again to post with those users from the frontend & backend.

    Thread Starter taxlawmen

    (@taxlawmen1)

    Hi,
    I tested what you mentioned.

    1.
    Log-in with each user and check if you are able to post via the frontend form and via the backend (Dashboard => Posts => Add new).

    → result
    1) frontend: Not Post published
    2) backend: Post published

    2.
    Then, change Rule 2 cycle into ‘none’, and try again to post with those users from the frontend & backend.

    → result
    1) frontend: Not Post published
    2) backend: Post published

    Posts were published at the backend to limit.
    And after that, I couldn’t publish it additionally. (message: Posts limit exceeded (Delete permanently: 1 post))

    Plugin Author Condless

    (@condless)

    Hi, please try to disable the ‘Role Base’ form option (Dashboard => User Frontend => Post Forms => Edit Post Form => Settings => Submission Restrictions => Role Base)

    Thread Starter taxlawmen

    (@taxlawmen1)

    I deactivated the option you told me.
    And I confirmed that the problem I mentioned has been solved.
    The limit setting works.
    Thank you.

    One question is, then do I always have to disable that option to use the limit setting?
    That is, will there be a conflict if I activate that option?

    Plugin Author Condless

    (@condless)

    In the next version of WP User Frontend plugin it will be fixed and you will be able to activate this option with no conflicts.

    Thread Starter taxlawmen

    (@taxlawmen1)

    Wow!
    Thank you.
    Thanks to your help, I can go one step further with my plan.
    Have a nice day.^^

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘I think week, month and year are not working during cycle setting.’ is closed to new replies.