[closed] I think my visitors are getting an "Error" page upon entry. (4 posts)

  1. litrags
    Posted 4 years ago #

    I hope someone can help. In the past some people I know had mentioned getting an error message when visiting my site. I thought I fixed it with some help, but that person is no longer helping me, and I fear it wasn't fixed in the first place. Too many people who come to my site only stay a second, even after I see that they were looking for my site--I.E. after articles in the New York Times and the LA Times. It doesn't make sense, and I don't know how to fix it or what pecentage is actually getting the message.
    My site is http://www.literaryrags.com
    Also, people using certain versions of Macs can't see the BUY button??? But the above problem seems more pressing.
    Thank you for any help!!!

  2. You have a huge number of validation errors that will definitely cause display issues in various browsers. They should be fixed.

    HTML: http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fliteraryrags.com%2F

    CSS: http://jigsaw.w3.org/css-validator/validator?profile=css21&warning=0&uri=http%3A%2F%2Fliteraryrags.com%2F

    In the past some people I know had mentioned getting an error message when visiting my site

    I got a really bad JavaScript error that may be what those folks were referring to - you need to fix it. You can see JavaScript errors in many browsers. In FF3, for example, look under Tools > Error Console.

    Error: uncaught exception: [Exception... "Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.getService]" nsresult: "0x80570018 (NS_ERROR_XPC_BAD_IID)" location: "JS frame :: chrome://webdeveloper/content/tools.js :: webdeveloper_isJavaEnabled :: line 4" data: no]

    It also shows a syntax error:

    Error: syntax error
    Source File: about:blank
    Line: 1, Column: 63
    Source Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"><html><head><title></title></head><body></body></html>

    You might also want to also reconsider your document type:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"

    Your code does not match this at all, you might want to try HTML 4 Transitional instead.

  3. litrags
    Posted 4 years ago #

    Thank you for the info. But the problem is I don't know how to fix it. My role in my website was the art and the authors -- I was a Lit. major. And the person who helped me build the site no longer available.

    I gave the company to my son due to bad health on my end, and I would like this fixed, as he is only 16. Would you happen to know someone who could fix this problem at a reasonable rate?

    I would be speechlessly thankful if someone was to help me with this.


  4. You could post an ad in WordPress Jobs to find someone who can help. Best of luck.

    I am closing this thread now.

Topic Closed

This topic has been closed to new replies.

About this Topic