Support » Installing WordPress » I think I’ve made a mistake with my install

  • Apologies if I’m being very dim but I’m new to all this — never tried to install software on a server before!
    I changed the login form correctly, I think, and I expanded and uploaded the files OK.
    I put them in the /public directory, because website stuff needs to go in there — I think.
    I ran the install.php script OK and it seemed to be happy. But at the end, it didn’t seem to give me a password, just empty quotation marks, and when I clicked on log-in, it 404ed.
    Probably I have made an elementary error, but I;m not sure what to do now! Any ideas?
    Thanks in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • u did not mention anything about databases… but since u said install worked fine other than the password part, i guess u made a database, a user and assigned it to the databsae…
    try to reinstall after cleaning the database 🙂

    Another query, on the wp-config.php file… I’m a bit confused ab0ut whether to use
    define(‘DB_NAME’, ‘blog1’); // The name of the database
    define(‘DB_USER’, ‘XXX’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘XXX’); // …and password
    define(‘DB_NAME’, ‘grievou_blog1’); // The name of the database
    define(‘DB_USER’, ‘grievou_XXX); // Your MySQL username
    define(‘DB_PASSWORD’, ‘XXX’); // …and password
    I only because the MySQL settings seemed to add the “grievou_” prefix to the database name and the user name…
    Also, am I right in thinking that I need to upload to the top directory, not a subdirectory?
    Thanks again

    Mark (podz)


    Support Maven

    If the SQL is adding grievou, then that’s what I would put there too. It’s similar to how my SQL works.
    And WP can be installed in any directory, though practically most people would put it into a top-level of one below that.

    Still no joy. I have:
    * deleted everything from my webspace
    * created a new directory for the blog
    * made sure the wp-config file had the right information in it, as specified by the mysql app on my web control panel
    * uploaded the whole wp package to the blog directory
    * checked that the wp-config file had the info it needed — found it was blank — added the correct text — checked it several times.
    * checked the mySQL account maintenance page and made sure I was added as a user and saw various connection strings appear
    * went to wp-admin/install-config.php and filled in the database name, username, password, and host name with the same info as was in the wp-config file
    * hit the “submit” button and got the 404 “server was not able to find the document /install-config.php”. But it is there, in the right place.
    * tried to run the install program anyway, and got the error message “server was not able to find the document /install.php”
    This is getting difficult… would I be better off with moveable type or something?

    Well, I’ve checked and re-checked the config file and the database, user name etc are all as they are supposed to be. Clicking on “Show file” for install.php comes up with the following message alongside the normal text:
    create one before moving on.”);
    $step = $HTTP_GET_VARS[‘step’];
    if (!$step) $step = 0;
    $installed = $wpdb->get_results(“SELECT * FROM $tableusers”);
    if ($installed) die(‘You appear to already have WordPress installed. If you would like to reinstall please clear your old database files first.’);
    So it says it’s installed. I haven’t created any blog entries or anything, so I assume that means my database files are clear. So I click on “let’s go!” and get a 404.
    This file goes on to say things like “Categories are up and running…”, “Comments are groovy…” etc. I put in the URL of the blog, hit the Step 3 button, and get a 404.
    Still don’t get a password; going to the admin screen just 404s.
    Do I need to delete the mysql database I set up and start again? Is there something obvious I am doing wrong?

    Just deleted everything — including all the sql databases, and added them again. Re-uploaded word press, checked the wp-config.php file on the server, file contents were all correct, but suffix of .txt had been added. I deleted the suffix using the change name utility (in CPanel — I’m with P4host).
    Tried install.php, it said there was already word press installed (?? I deleted the whole directory and all databases!), and 404ed when I put in the url of the blog and went to step 3.
    Really lost here — there must be something I can change?

    Looking in phpMyAdmin the blog database exists but has no fields, structure etc. Dunno if this helps.
    P4host seems up to date with its PERL and sql BTW.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘I think I’ve made a mistake with my install’ is closed to new replies.