Support » Plugin: Decision Tree » I think it died.

Viewing 15 replies - 16 through 30 (of 49 total)
  • What about a timed out connection? Does the session expire? I’m a little shaky on that stuff, so sorry if this doesn’t make good sense.

    Oh hey, you guys just released a new version. Let me try that!

    Ah – yes, a new version! However, all we did is to call out that your problem exists on the FAQ:

    Q I was working on a DT and it broke: the last step is out of order and I can’t delete it!?!

    A We’ve had a few users report that their DTs have problem when they’re editing them. Specifically, the step number will jump to be out of order and they can no longer publish the DT. We’re aware of the issue and are trying to fix it. Please let us know if you have any details on how to reproduce the issue!

    Oh, nice. I’m one of the cool kids on the bleeding edge of the DT community! haha

    I just deleted my two DTs, but the rows are still shown in wp_3_postmeta (the postmeta table for this node of the multisite). A third one shows from my last install as well. Are these rows not deleted when the plugin is removed? I trust what you say that they won’t affect new DTs, but it seems this data should be cleared (maybe optionally with a checkbox) when the plugin is removed.

    Example:

    138	57	dtree_blob	{\"data\":{\"1\":{\"question\":\"Select your program:\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Emergency Medical Technician - Basic\",\"next\":\"49\"},{\"choice\":\"Emergency Medical Technician - Intermediate\",\"next\":\"6...

    Man, I am still blowing it up. Here’s what I just did.

    1 .Deleted all DTs (data still in database).
    2. Deactivated and removed DT plugin.
    3. Added and activated latest DT plugin.
    4. Created a new DT
    5. Added 3 choices to the first question
    6. Created a new step, Placeholder Answer
    7. Pointed all 3 answers to the Placeholder
    8. Created a new step for sub-question for Question 1.1 with 3 choices
    9. Made 3 new steps for those answers, filled with text and URLs, using the new feature to split them up

    Error:
    10. Added a new step to make a sub-question for 1.2
    – It is labelled Step 19
    – Noting the number being so high, I delete it and it also deletes out the data from Step 7, which was 1.3 sub-question’s answer
    – Step 7 is now renamed Step 6 and the fields are blank
    – I refresh the page to avoid losing data
    – This step is repeatable over and over

    Does this help?

    This is exactly what we were looking for, thanks! We’ll do some testing and get back to you.

    Some more troubleshooting info:

    I recreated my DT, still getting high step numbers after a few tries, following a long break and coming back to the site, refreshing before changing anything.

    I tried to add a new step, following my list of 20 or so. Option 1 has a sub-choice of 3. Those go to answers with links in the HTML box.

    I started on the next set and got 59, then 62 as I added steps. Then I got 9 and 10 after that, which is the normal sequence, since my last good step was 8.

    I tried adding choices to one of the bad items, the second one. It added the blank choices to step 8 above!

    Deleting the bad numbers removes the bad step and the previous good step. It seems like some kind of an array reference issue, perhaps in the way the JSON is created and edited during these steps. Maybe I’m wrong!

    Now I’m getting them in a random order after forcing through another branch. I had to delete the high numbers and recreate the steps that were also blanked in that process. Now my order of steps is out of sequence. I thought this may be additionally useful info. The first few steps seem to be preserved, but after that, they get a little wonky.

    Here’s an outline:
    Step 1) Big 20 choice
    Step 2) Placeholder answer for saving as I go
    Step 3) 1.1 sub-choice question
    Step 4) 1.1.1 answer
    // up until here, all is well – the following items are out of order
    Step 5) 1.3 sub-choice question
    Step 6) 1.1.2 answer
    Step 7) 1.3.1 answer
    Step 8) 1.1.3 answer
    Step 9) 1.3.2 answer
    Step 10) 1.2 sub-choice question
    Step 11) 1.3.3 answer
    Step 12) 1.2.1 answer
    Step 13) 1.2.2 answer
    Step 14) 1.2.3 answer

    I originally created these in sequenced order, so I think t’s safe to say the JSON is going a little bananas. 🙂

    We’re still working on this! Stay tuned.

    That’s great! I shopped around and still plan to use this tool if possible.

    James – Sorry, we’ve been unable to reproduce your issue after reading through your notes. Can you let us know which OS and browser you’re using? As well, it’d be really great if we could see a video of exactly how you make your DTs that get corrupted. Could you try using http://www.screencast-o-matic.com/screen_recorder or https://www.screenr.com/ do make one? You’re welcome to use any other method if you have another you prefer.

    Thanks so much for all your patience!

    I’m using Windows 10 tech preview and Chrome Version 43.0.2357.134 m (64-bit). I don’t know if I’ll have a chance to video the process, since I’m at work. Would the JSON dump help?

    The first link one won’t work in recent Chrome, just a heads-up. 🙂
    https://support.google.com/chrome/answer/6213033

    The second one isn’t working either. I’ll try another browser.

    Here’s the value from dtree_blob for the post I am working on , number 60.

    [Large code excerpt removed by moderator per forum rules. Please use the pastebin for all large code excerpts. It works better anyway.]

Viewing 15 replies - 16 through 30 (of 49 total)
  • The topic ‘I think it died.’ is closed to new replies.