Support » Plugin: Variation Swatches for WooCommerce » I see no swatches at all!

  • Resolved Nikhil Varma

    (@nikhil-varma)


    The default WC drop down is gone, COLORS attribute word is shown, but no swatches!
    What could be wrong?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Emran Ahmed

    (@emranahmed)

    Hi Nikhil,

    Could you please share your site link to check?

    You can check this youtube video also: https://www.youtube.com/watch?v=k-Snfpzy8M0

    Thank you

    Thanks for the qucik response, as I continue to try more plugins. In fact I was happily using a plugin of the same name, but it now has not been updated since 9 months, and wondered if it was my theme or the latest WP that made it not show those nice color swatches anymore.

    Discovered your plugin and tried, more so since it has been tested for the latest WP and you seem to update it frequently!

    Now, to your question πŸ™‚
    >> I am working on a staging site. So how do I show it to you?
    >> I am not a developer but a designer. The theme I am using is Tesla Theme’s NARCOS.
    THIS THEME
    >> Using WP 4.9.4, Latest WC 3.3.3

    • This reply was modified 2 years, 6 months ago by Nikhil Varma.
    Plugin Author Emran Ahmed

    (@emranahmed)

    You can make a quick video with useloom.com and you can give me a copy to test it.

    For Quick discussion Join our facebook group.

    Thank you

    I have a question…

    There was a plugin I mentioned earlier.
    Only after installing that plugin, did I see an option of “Type” choices for Attributes. And so I defined color values for type>Color.

    After deactivating that plugin, the type choices disappear from Attributes.

    But then, installing and activating your plugin, those choices reappear, and lo! my set of 30 colors that were defined are intact!

    NOW, would it be the case that I must remove all these and redefine (again) all colors to work with your plugin?

    From the behaviour I concluded so:
    1. WC is holding the attributes (not plugins)
    2. Plugins are holding color values and “types” (something WC alone did not show)
    3. The type is somehow persistent and stays within the db of WC
    ?? So is 3 the reason for no color swatches showing up?

    Your plugin is functioning, at least by not showing the colors drop down list of WC. And so my hope that something can be done πŸ™‚

    • This reply was modified 2 years, 6 months ago by Nikhil Varma.

    Reporting more…

    1. If the variations are created using the form interface of WC, the swatches show.
    2. If products and its variants are imported using the import products via CSV option of WC, the products show, but no swatches.

    OK. Finally I have done the video. Thanks for sharing about useloom.
    Hope this video helps diagnose.

    https://www.useloom.com/share/74d3ae02b70045bebce172dc3818ca21

    Thanks!

    • This reply was modified 2 years, 6 months ago by Nikhil Varma.
    Plugin Author Emran Ahmed

    (@emranahmed)

    Hello @nikhil-varma,

    I just made an update based on your report. Please update to 1.0.15,

    If you use custom product attribute from product page, It will show a dropdown list. I checked your video: your product had custom product attribute which id may not same as imported one.

    Hope this version fix it.

    Plugin Author Emran Ahmed

    (@emranahmed)

    And I am really thankful for your report and help πŸ™‚

    Thanks very much!
    It now works for uploading products using CSV file.

    By exporting from WC and comparing with my file I learnt that it is important:
    1. Column (field) named “Attribute 1 global” should be “1”. Else swatches wont show.
    2. Column (field) named “Attribute 1 value(s)” should have the list of ALL the “values” of the attribute 1. In my case it meant, the list of all color names separated by commas.

    Now, I have a problem of another kind, seeing it only now:
    >> The column “position” to set the sequence of the swatches, does not seem to have any effect. No matter how I make the list of names (2 above), they get sorted alphabetically. Any way to control the sequence of the swatches? I am using some 29 colors!

    Plugin Author Emran Ahmed

    (@emranahmed)

    You have to sort it from product variation tab. btw a quick video will help to understand using useloom.

    Thank you

    Hi,

    I noticed a setting, and checked that it is set correctly, but not behaving as it should.

    Products>Edit attribute>
    “Default sort order” << is set to “Custom ordering”

    And yet, the uploads sort my list of attribute values alphabetically. Is this WC bug or due to the plugin?

    Thanks.

    Hey I have managed to solve it!

    1. The “custom ordering” does not mean the ordering of color (attribute) values in the exported csv per product, rather the ordering in the Attributes listing.
    2. I ordered the colors in that list simply by drag-and-drop. And it has worked!
    Note: Since I had 30 values, I had to change the page settings to increase the number of items shown per page, to be able to sort the list. I was stuck for a while wondering how to order across pages!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘I see no swatches at all!’ is closed to new replies.