Support » Fixing WordPress » I see "Deprecated" error everywhere in dashboard

  • Hello,
    I get this message everywhere:

    Deprecated: Assigning the return value of new by reference is deprecated in /wp-includes/class-simplepie.php on line 738

    [ Repetitive and redundant lines of log moderated. ]

    WP version: 3.3
    After update to 3.3.1 problem stil exists

    REcently changed from 5.2 to 5.3 Php – maybe thats the problem ? I tried to revert back to 5.2 but no effect.

    I tried to deacivate and activate all my plugins one at a time but it didnt work out either.
    Deletion of plugins phisically didn’t resolve it.

    Any sudgestions friends ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    I think we got the error message after the first couple of times or so. 😉

    Can you try both deactivating the plugins and switching to the Twenty Eleven theme?

    Also have you tried uploading a fresh copy of WordPress 3.3 on top of your WordPress files? Unless you modified a core file (always a bad idea) that will not harm your install.

    http://codex.wordpress.org/Updating_WordPress#Manual_Update

    Jan, the problem is coming from simplepie. I’ve reported this but they don’t want to use a newer version of simplepie (claiming they want PHP v4 support – now get this, wordpress only works with PHP 5+!!)

    Moderator Sergey Biryukov

    (@sergeybiryukov)

    WordPress Dev

    claiming they want PHP v4 support – now get this, wordpress only works with PHP 5+!!

    According to Ryan’s reply, it’s not that they still want PHP 4 support in WordPress, it’s that 1.3-dev version (where those notices are fixed) is not quite ready yet and needs more work on other features and bug fixes.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘I see "Deprecated" error everywhere in dashboard’ is closed to new replies.