[resolved] I need help validating RSS Feed! (5 posts)

  1. iyiinsan
    Posted 10 years ago #

    A few days ago I posted something about feeds working in Mac but not in Windows. Well, it isn't solved or anything, but I'm over that; I have a bigger problem.

    I am a member of a site which needs a valid RSS feed address, which I once had when I was using Blogger but disappeared when I switched to WordPress. So, my membership is threatened and if I don't show them a valid feed address in a week or so, my membership will be gone.

    My problem is -probably- about encoding. When I use FeedValidator to check my RSS Feed, I get this;

    • Your feed appears to be encoded as "UTF-8", but your server is reporting "ISO 8859-9"

    • line 1, column 33: XML parsing error: <unknown>:1:33: XML declaration not well-formed

    The thing is, I have to use ISO 8859-9 (or Windows-1254 or ISO Latin 5) because UTF-8 causes some serious problems in my blog. Weirdly enough, nothing like this happens to my friends whom which I don't know what kind of server software they use, but happens to me with both an Apache installation my hosting company offers and an Abyss installation at home...

    http://www.feedvalidator.org/check.cgi?url=http%3A%2F%2Fiyiinsan.net%2Fwordpress%2Fwp-rss2.php#l1 is the feed validator address.
    And for more information, iyiinsan.net/wordpress/feed/ doesn't "exist".

    It looks like I need a *lot* of help...
    Thanks in advance to whom all can answer...

  2. Beel
    Posted 10 years ago #

    You have entered your character encoding incorrectly in the options.

  3. iyiinsan
    Posted 10 years ago #

    How should I enter it? I clicked on the link on the admin page (where it says UTF-8 is recommended in parantheses) and I tried "latin5" which gives me "Obscure XML character encoding: latin5" with a "^" below the "a" of "latin". I also tried ISO-8859-9, but it gave the same error, with the sign below the "S"... ISO-8859 didn't work at all, the characters were all scrambled on the main page.

  4. iyiinsan
    Posted 10 years ago #

    Oh my God! You are a genius... and yeah, I'm an idiot! I just tried windows-1254 and it worked!
    Thank you so much Beel!

  5. Beel
    Posted 10 years ago #

    You can use what you had, though most around here apparently use utf-8. Just don't leave a space (it is "iso-" not "iso ")

Topic Closed

This topic has been closed to new replies.

About this Topic