Support » Themes and Templates » I need help: CSS problems – not compatible with IE8 / 9

  • I was encountered some compatibility issues, please see the following code:

    [CSS code moderated – please post a link to your site]

    The effect of screenshots:
    Chrome ,Firefox,Opera,Safari :
    http://i.imgur.com/6xk7I.jpg
    IE 8, IE9:
    http://i.imgur.com/Q8OHd.jpg

    In the Chrome, Firefox, Opera,, Safari does not appear what the error,

    But in IE8 / 9, have the problem, but I could not find the problem, please help me how to modify the above CSS code to solve the problem, or there is another way, thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator t-p

    (@t-p)

    have you tried conditional comment CSS

    I have yet to create a site, I set up a local development environment.
    I am now making theme.

    WPyogi

    (@wpyogi)

    Forum Moderator

    Unless someone can actually look at the code in the site, it’s pretty impossible to give you specific help. As suggested above, you can still use the conditional comment CSS on a local site — it just means you write a different version of CSS for certain browsers. Also, you might try validating your site to make sure you don’t have any CSS or markup errors that might be contributing to the problems.

    [mod: please mark any direct posted code using backticks or the code button – for any code over the forum limit of 10 lines, please use the pastebin]

    The main issue is in here: “<a href =" <? The php the_permalink ()?> "> <Img src =" <? Php the echo catch_that_image ()?> "Width =" 100 "height =" 100 "alt= "" />

    If I Delete the <a href = "<? The php the_permalink ()?>"> ,the side part is not compatible with IE8 / 9 above, occurs not display correctly.But obviously I can not put this code removed.

    The strange thing is, even if I do not do any deletion, the part in Chrome, Firefox, Safari, Opera, the above does not appear similar to IE8 / 9 error.

    Michael

    (@alchymyth)

    Forum Moderator

    that posted code does not have a link closing tag </a>;

    it mght help if you paste the full code of the template into a http://pastebin.com/ and post the link to it here.

    code pastebin.com:
    http://pastebin.com/n6Hma070

    Michael

    (@alchymyth)

    Forum Moderator

    definively close the a tag in line 14:

    <a href="<?php the_permalink() ?>" > <img src="<?php echo catch_that_image() ?>" width="115" height="115" alt=""/></a>

    if it is still not working, there is really not much anybody could suggest without being able to check the problem on a live site.

    Thank alchymyth!, The reason is the lack of </ a> caused by. Problem has been solved!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘I need help: CSS problems – not compatible with IE8 / 9’ is closed to new replies.