Support » Fixing WordPress » I messed up good.

  • So this is what I have done:
    I installed WP on my localhost. I exported my current WP database using a plugin thingy I found around here. Then I imported it to my localhost using phpmyadmin. For some reason, it imported all of my preferences too, so my localhost blog pointed to my *real* blog whenever I tried to edit it. So I went into my *real* blog and changed those preferences to point to my localhost, so that I could make my localhost preferences point to the localhost. I then successfully changed my localhost preferences to point to the localhost — only now they BOTH point to the localhost, and I cannot update or change my real blog. I get rerouted to my localhost every time. I cannot find where these preferences are stored, so I cannot change them manually.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Look at table wp_options, change the siteurl setting by using the browse function of PHPMyAdmin.

    OK, I did that. I can now access the login page correctly, at least. Only now, I cannot login. It does not recognize the password I’ve been using under the username “admin.”
    Grr. What gives?

    Using PHPMyAdmin, browse table wp_users, and edit the first user which is admin. For the key user_pass, enter a new password *and* make sure to select PASSWORD for the Function column.

    Followed that to the letter. Entered the database via phpmyadmin. went to wp_users table. Went to user_pass. Set the function to PASSWORD. Changed the password. Still doesn’t work. I’m not *that* bad a typist. I’m still lost.

    You can’t just enter a word. You need to md5 hash it.
    Look towards the end of that wiki page for details.

    Nope. Sorry to be such a bother, but that’s not it, either. I went to the hash generator, or whatever it’s called, and entered the password, and it gave me the code for it. I then went and entered it as the password, being careful to follow all the steps for entering a password that were previously outlined. But when I went to login, “admin” plus the password did not work.
    I have tried the “send me my password” function several times as well. Even though I am SURE that the username and password are correct, it tells me that the username is not recognized. I had three usernames before, and none of them work now. All of them are “not recognized,” not even when I have checked and double-checked that these are established usernames and the correct corresponding email addresses. It’s easy for me to check, since I just loaded all this information a few hours ago into my localhost. I can view my localhost settings and see that they have not changed, and still work on my localhost, with the same usernames, passwords, and emails that worked a few hours ago on my *real* host as well. My *real* host settings have somehow been fucked badly, and I don’t want to re-install the whole damn thing.

    If you’re brave and desperate and sober. This is risky since I have no clue how the plugin exports tables. I prefer to export using phpmyadmin.
    1. Delete WP and its db off your “localhost”.
    2. Drop the db for your “real”. (Use phpmyadmin)
    3. Recover the db using that first backup you made in your original post.
    4. Now using phpmyadmin, duplicate the db into a new db, which I will call “new_db”. Your “real” will still be using the original db.
    5. Change siteurl in new_db.
    6. Export new_db using phpmyadmin.
    7. Use this exported new_db for your localhost WP.
    8. Just for the heck of it, delete your cookies and cache and do ten jumping jacks.
    9. If something is still messed up, I blame your host configuration.

    Thanks. I jumped through some different hoops myself to fix it:

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘I messed up good.’ is closed to new replies.