Support » Localhost Installs » I m going crazy…

  • Hey guys,
    I have maybe testet 10 times the local installation and it doent work but the crazy thing when i tried it in the notebook by my friend, the installation works perfectly for him with the same approach what i tried it for myself.

    What i am doing:
    1. Download XAMPP for Windows and download wordpress and extract it.
    2. Install it and put wordpress in htdocs file.
    3. Go to http://localhost/phpmyadmin/index.php and make a databank
    4. open the databank, go to privileges and give a username, ect
    5. Global privileges: Check all –> ok
    6. Go to http://localhost/wordpress/wp-admin/setup-config.php?step=1
    7. Give all information and click Submit

    And then it appears:
    “Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at localhost. This could mean your host’s database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?”

    I dont understand it because it when i did the installation for my friend it worked perfectly…same approach. It doesnt make sense!!!
    I looked every tutorial but I dont find any solution. How I said i tried the installation then times and different disk.

    Anyone with a solution. I m going crazyyyy….

    • This topic was modified 11 months, 1 week ago by  jonasjonas.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi.,

    I think you are confused with database username, password with site username and password

    By default database username is “root” and password is “” (empty)

    Just try that

    Thanks

    Actually the password settings are different on the operative systems – are you on a Mac or a Windows system? Here is a tutorial with instructions for Mac, Windows and Linux. Hope that this will help you:

    Set up WordPress on XAMPP on Linux, Window or Mac

    If you’re on a Mac also remember to give correct permissions in the server folders.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘I m going crazy…’ is closed to new replies.