Support » Plugin: Swift Control - A Better WordPress Admin Bar » I like the idea of operating from my front-end backward

  • Resolved nealumphred

    (@nealumphred)


    DAVID

    I am using WordPress 5.3.2 with Classic Editor and the current GeneratePress theme. I am giving your Swift Control plugin a try as I like the idea of operating from my front-end backward rather than logging into my editor and maneuvering around from there. Here are my experiences and responses so far:

    1. The default settings show one square on the front end with a gear in it and a moving arrow next to it. I really don’t like the arrow. If you are going to keep it, please consider an option in the settings where users can disable it.

    2. When I click on the purple gear square, three more squares drop down below it: Dashboard, Disabled, and Customize.

    a. What is the Disabled option for?
    b. When I click on each square, a gray rectangle with a title opens alongside it. The red text is difficult to read. Please consider changing it to white or giving users the option to change those colors in the settings.

    2. First thing I did was change the default colors but changing them had an odd effect: It turned all the icons in the squares into rectangles. Is that intentional or did I do something incorrectly?

    3. All the squares on my front end keep shaking, making me nervous just seeing them. Is that intentional?

    That’s it for now.

    NEAL

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 35 total)
  • Thread Starter nealumphred

    (@nealumphred)

    D

    Anything?

    N

    Plugin Author David Vongries

    (@davidvongries)

    Hi Neal,

    GeneratePress’ inline styles are overriding ours. That’s why the text is being displayed in red. Here’s what they do:

    .widget-title {
        font-size: 16px !important;
        color: #b80000 !important;
        font-family: Arial Black !important;
    }

    I’m not sure why !important is being used here but that’s what’s causing the issue.

    I think this referes to the sidebar settings. Tweaking those may solve the issue for you.

    Thread Starter nealumphred

    (@nealumphred)

    D

    All of my sites are identical: same theme, same plugins. Yet the text appears white on one site and red on the others. Why is that?

    N

    Plugin Author David Vongries

    (@davidvongries)

    Hi Neal,

    As mentioned in my previous reply I think it’s related to the theme’s sidebar settings. Those use !important and override our widget settings.

    Best,
    David

    Thread Starter nealumphred

    (@nealumphred)

    D

    I tweaked the code for the widget-title and was able to keep the formatting I wanted but eliminate the “important” and now text on the WP Swift Control is white instead of red.

    Thanks!

    N

    Plugin Author David Vongries

    (@davidvongries)

    Awesome! πŸ™‚

    Another thing I’ve noticed is that GP adds this as well:

    .widget-title {
        margin-bottom: 30px;
    }

    You should be able to remove this by adding the follwoing CSS:

    .swift-control-widgets .widget-title {
        margin-bottom: 0;
    }

    Best,
    David

    Thread Starter nealumphred

    (@nealumphred)

    D

    Thanks!

    Is there a way for me to control the positioning of the WP Swift Control panel? I would like to move it up?

    N

    Plugin Author David Vongries

    (@davidvongries)

    Yes, drag & drop it πŸ™‚

    Thread Starter nealumphred

    (@nealumphred)

    FD

    Hah! It worked.

    Never dawned on me to try something so simple.

    Thanks again.

    N

    Plugin Author David Vongries

    (@davidvongries)

    Hehe, it’s a new feature that we’ve added with the latest release πŸ™‚

    Best,
    David

    Plugin Author David Vongries

    (@davidvongries)

    We’ve just released an update (1.4.1) and there should no longer be incompatibility issues with other themes or plugins now πŸ™‚

    Just wanted to let you know.

    Best,
    David

    Thread Starter nealumphred

    (@nealumphred)

    D

    Thanks for the heads-up, but when I updated the plugin to 1.4.1, all the Swift control panels on my homepage disappeared. So I rolled it back to 1.4.

    N

    Plugin Author David Vongries

    (@davidvongries)

    That sounds like a caching issue to me. Are you using any caching plugins or server-side cache?

    Thread Starter nealumphred

    (@nealumphred)

    Cleared WP Fastest Cache, Autoptimize, and Cloudflare at the CDN site. Still no Swift Control panels on the homepage.

    I have Swift Control 1.4.1 active on this site: http://www.theendlesssixties.com

    Plugin Author David Vongries

    (@davidvongries)

    That’s strange.

    I tried to log into your site with the credentials you provided earlier but it seems like they no longer work.

    Wanted to have a quick look at it.

Viewing 15 replies - 16 through 30 (of 35 total)
  • The topic ‘I like the idea of operating from my front-end backward’ is closed to new replies.