Support » Plugin: WP Swift Control » I like the idea of operating from my front-end backward

  • Resolved nealumphred

    (@nealumphred)


    DAVID

    I am using WordPress 5.3.2 with Classic Editor and the current GeneratePress theme. I am giving your Swift Control plugin a try as I like the idea of operating from my front-end backward rather than logging into my editor and maneuvering around from there. Here are my experiences and responses so far:

    1. The default settings show one square on the front end with a gear in it and a moving arrow next to it. I really don’t like the arrow. If you are going to keep it, please consider an option in the settings where users can disable it.

    2. When I click on the purple gear square, three more squares drop down below it: Dashboard, Disabled, and Customize.

    a. What is the Disabled option for?
    b. When I click on each square, a gray rectangle with a title opens alongside it. The red text is difficult to read. Please consider changing it to white or giving users the option to change those colors in the settings.

    2. First thing I did was change the default colors but changing them had an odd effect: It turned all the icons in the squares into rectangles. Is that intentional or did I do something incorrectly?

    3. All the squares on my front end keep shaking, making me nervous just seeing them. Is that intentional?

    That’s it for now.

    NEAL

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 35 total)
  • Plugin Author David Vongries

    (@davidvongries)

    Hi Neal,

    We’re working on some different styling options but for now I’d suggest to hide the arrow with CSS. You can add the code below under Additional CSS in the WordPress cusotmizer for instance:

    .swift-control-widgets .widget-setting::after {
    	display: none;
    }

    The “Disabled” one will say “Edit Post” on posts, “Edit Page” on pages, etc. On archives, it’s shown as “Disabled” by default. We though if we should simply remove it from archives but figured that may cause confusion as well.

    The text should be white actually. It may be the case that the theme overrides the Swift Control CSS in your case.

    Regarding the icons turning into squares, that sounds like a FontAwesome issue. Can you please try to tick the box that says “Disable FontAwesome 5” on the Swift Control settings page? If that doesn’t fix it, can you please share a screenshot of the issue with me?

    The squares shouldn’t be shaking either! That’s really strange. Feel free to create a quick video on this so I can see what’s happening here.

    Thanks!

    Best,
    David

    D

    Thanks for the prompt response!

    1. I added the code to my Customizer and the arrow disappeared.

    2. Ah! I hadn’t gotten as far as opening a post but I just did and the Disabled square transformed into an Edit Post square. Also, on a post, the icons returned. But on a page, the Disabled square remains disabled and the icons remain rectangles.

    3. When I added the disable-arrow code to my Customizer the squares stopped shaking!

    So, the icons are icons on posts but are replaced by rectangles on the homepage and on pages. How do I share a screenshot here?

    N

    Plugin Author David Vongries

    (@davidvongries)

    Hey Neal,

    Regarding the rectangles, I think we have a conflict with a plugin or theme loading FontAwesome (possibly a version prior 5) – can you please try to disable other 3rd party plugins to see if the issue goes away?

    Have you tried to disable FontAwesome on the Swift Control settings page?

    I think you can’t post a screenshot here. You’d have to upload it to the dropbox for instance and share the link instead.

    Best,
    David

    HEY, DAVID!

    I deactivated ALL plugins but the rectangles remained.

    I have the Don’t load FontAwesome 5 option ticked.

    I do not know how to upload a file to a dropbox here. Instead, I added the screenshot to one of my pages:

    A Little Background

    Scroll down to the bottom and there is the screenshot of the top portion of the site’s home page. Click on the image and it will enlarge.

    Hope this helps.

    NEAL

    • This reply was modified 6 months, 1 week ago by nealumphred.
    Plugin Author David Vongries

    (@davidvongries)

    Hey Neal,

    so no matter if you check/uncheck the FontAwesome checkbox it doesn’t make any difference, is that correct?

    What theme are you using? It may be an issue related to the theme then if the issue still remains with all other plugins deactivated.

    Thanks for the screenshot! 🙂

    Best,
    David

    D

    Hah! I automatically checked the FontAwesone box without even testing it. So I just unchecked the box and the icons are back and working!

    Thanks!!!

    It’s 3AM here and I need a little sleep.

    I will be back later.

    N

    Plugin Author David Vongries

    (@davidvongries)

    Glad it’s working now! 🙂

    D

    Okay—I now have Swift Control on all six of my sites. Each is working fine. But there’s something odd: On five sites, the print on the gray title tags that pop up when I click on one of the icon squares remains dark red, which is difficult to read.

    But on one, the print has turned to a much more readable white.

    What’s up with that?

    N

    nealumphred

    (@nealumphred)

    D

    Thanks for the recent changes. I was going to ask if there was a way to keep the squares visible all the time. Only thing is that you dropped the placement of the square with the gear about 100 pixels down the left side. If I select all the options, the last squares are below the bottom of my computer screen.

    Also, the text in the title tags is still white-on-gray on one of my sites but red-on-gray on the others.

    N

    Plugin Author David Vongries

    (@davidvongries)

    Hi Neal,

    can you please create a ticket and send over admin credentials so I can have a look at one of the sites where the tooltips are red on gray?

    https://wpswiftcontrol.com/support/

    nealumphred

    (@nealumphred)

    D

    Temporary admin access to GCC – Global Climate Change was sent via support ticket.

    Good luck!

    N

    D

    You still alive?

    N

    Plugin Author David Vongries

    (@davidvongries)

    Hi Neal,

    I replied to your ticket on February 9th. Did it land in your spam folder maybe? Here’s my reply:

    Hi Neal,

    Thanks for sending over the details.

    I can’t login with that username, it said: Invalid email address or incorrect password.

    Looks like I need an email address to login.

    Best,
    David

    D

    If I received your email, I did not see it.

    Apologies for not including an email. Try this: wardcisred@hotmail.com

    Best,

    N

    PS: When I come here to WordPress.org with support questions, most of the time I do not receive an email notification when a response has been posted to my question.

    And I always tick the Notify me of follow-up replies via email box below.

Viewing 15 replies - 1 through 15 (of 35 total)
  • You must be logged in to reply to this topic.