Support » Plugin: wp-Typography » I like it BUT

  • smart quotes do not work! That’s not acceptable.
    Also I think the settings UI could be simplified.
    ___

    Die Umwandlung von Anführungszeichen funktioniert nicht (Inkompatibilität mit PHP7? Nur eine Vermutung.)
    Die Einstellungs-Oberfläche könnte vereinfacht und aufgeräumt werden.

    Die deutsche Übersetzung des Plugins ist sehr unvollständig. Trotzdem heißt es auf der Übersetzungsseite, die Übersetzung sei zu 100% abgeschlossen! Ist für mich unverständlich…

    EDIT: The bug is gone.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author pepe

    (@pputzer)

    I’m sorry that smart quotes don’t work in your setup, in general they do. What version of WordPress and which theme are you using? Would you have an example page or a screenshot I could look at?

    Also, regarding the settings page, I agree it can be quite overwhelming. If you have any specific suggestions on how to simplify things, I’d be happy to talk about them here in the support forum or on Github.

    Addendum/Answer to the German part: The translation is complete, but GlotPress has not pushed a new language pack – this is outside of my control as a developer/translator. I believe I know why this is the case (GlotPress chokes on the included hyphenation pattern files – a fix had been promised in January, but this has been postponed several times) and I’m working on a version that works around this limitation by using JSON instead.

    As for PHP 7, that should defintely not be the problem with smart quotes – I’m using 7.0.5 on my own site.

    Thread Starter aurban

    (@aurban)

    The bug seems to be gone. Some time ago I manually changed quotes to German smart quotes („“) because the plugin changed them to English smart quotes, although I didn’t change the settings.
    Now I tried to reproduce the bug but everything seems to be fine. You get one more star 🙂

    Plugin Author pepe

    (@pputzer)

    Thank you.

    It’s probably no consolation, but from the now-closed bug report on Github, I think I know what happened: You hit version 3.2.0, which was bad. It was only online a few hours, but it missed the the_content filter so smart quotes (and all other typography fixes) in the content would not show up. If you then manually changed typewriter quotes to smart quotes directly in the content, new versions of wp-Typography don’t do anything with those, by design. (The rationale is that if you typeset special characters in your content, odds are that you want them to appear exactly in that way.)

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘I like it BUT’ is closed to new replies.