Support » Plugin: Yoast SEO » I keep getting Yoast SEO had problems creating the database tables

  • Resolved Manny

    (@thewebnerd)


    I keep getting the below messages on all our sites that we updated Yoast’s newest version.

    “I keep getting Yoast SEO had problems creating the database tables needed to speed up your site. Please read this help article to find out how to resolve this problem. Your site will continue to work normally, but won’t take full advantage of Yoast SEO. Show debug information”

    I emailed my host and they said they have database permission for Yoast for the required tables. They reset the permission I even tried deactivating and reactivating the plugin.

    I also look at the wp-config and it is up to date. Can you help?
    Thank you

    • This topic was modified 11 months, 1 week ago by Manny.
Viewing 15 replies - 1 through 15 (of 18 total)
  • https://github.com/Yoast/wordpress-seo/issues/15098

    Warning! This can reset all you plugins and custom theme settings.

    Thread Starter Manny

    (@thewebnerd)

    Samantha, the trend you sent is not helpful. Can someone from Yoast please respond.

    Plugin Support Michael Tina

    (@mikes41720)

    @thewebnerd we apologize for any issues you’re encountering with Yoast SEO. Could you please confirm you’re using v14.1 of Yoast SEO for WordPress and could you please provide us with the debug information so we can learn more about the possible cause behind this? Thank you.

    Hi,
    I also have same issue and i believe many have as well after 14.1 updates.
    Additionally when i use sitemap , it crushes totally.

    You have a post about this issue but it does not give any solution and host companies do not resolve it because it is not related to them.
    It was working fine before update, and after updates this problem occurred.

    https://yoast.com/help/cannot-create-database-tables/

    Thread Starter Manny

    (@thewebnerd)

    Hi, Micheal, I included the error in the original message but here it is again: Yoast SEO had problems creating the database tables needed to speed up your site. Please read this help article to find out how to resolve this problem. Your site will continue to work normally, but won’t take full advantage of Yoast SEO. Show debug information”

    I spoke with my host and they said that all permission was allowed.

    same issue here also!

    Erich

    (@erichboileau)

    Same issue here. Looking forward to a solution! 🙂

    Same issue here !

    Debug information :
    AddCollationToTables – Error executing ‘query’ with: ALTER TABLE wpca_yoast_migrations CONVERT TO CHARACTER SET utf8mb4_unicode_ci Reason: Unknown character set: ‘utf8mb4_unicode_ci’

    @mikes41720 I got the problem. Below is the debug information. Could you help me?

    WpYoastIndexable – Error executing ‘query’ with:

    CREATE TABLE wp4_yoast_indexable ( id int(11) UNSIGNED auto_increment NOT NULL, permalink mediumtext, permalink_hash varchar(191), object_id int(11) UNSIGNED, object_type varchar(32) NOT NULL, object_sub_type varchar(32), author_id int(11) UNSIGNED, post_parent int(11) UNSIGNED, title varchar(191), description text, breadcrumb_title varchar(191), post_status varchar(191), is_public tinyint(1), is_protected tinyint(1) DEFAULT ‘0’, has_public_posts tinyint(1), number_of_pages int(11) UNSIGNED, canonical mediumtext, primary_focus_keyword varchar(191), primary_focus_keyword_score int(3), readability_score int(3), is_cornerstone tinyint(1) DEFAULT ‘0’, is_robots_noindex tinyint(1) DEFAULT ‘0’, is_robots_nofollow tinyint(1) DEFAULT ‘0’, is_robots_noarchive tinyint(1) DEFAULT ‘0’, is_robots_noimageindex tinyint(1) DEFAULT ‘0’, is_robots_nosnippet tinyint(1) DEFAULT ‘0’, twitter_title varchar(191), twitter_image mediumtext, twitter_description mediumtext, twitter_image_id varchar(191), twitter_image_source varchar(191), open_graph_title varchar(191), open_graph_description mediumtext, open_graph_image mediumtext, open_graph_image_id varchar(191), open_graph_image_source varchar(191), open_graph_image_meta text, link_count int(11), incoming_link_count int(11), prominent_words_version int(11) UNSIGNED, PRIMARY KEY (id)) DEFAULT CHARSET=utf8;

    Reason: Table ‘wp4_yoast_indexable’ already exists

    I’m having the same issue after updating to 4.1:

    Yoast SEO had problems creating the database tables needed to speed up your site.

    Please read this help article to find out how to resolve this problem.

    Your site will continue to work normally, but won’t take full advantage of Yoast SEO.

    Show debug information
    DeleteDuplicateIndexables – Error executing ‘query’ with: INSERT INTO wp_yoast_migrations (version) VALUES (‘20200507054848’) Reason: Duplicate entry ‘20200507054848’ for key ‘idx_wp_yoast_migrations_version’

    Plugin Support marcanor

    (@marcanor)

    Hi @thewebnerd, @ugurege , @bufoo , @erichboileau

    We understand that the error reports that the tables could not be created. We apologize for these issues during the latest update.

    Just to double-check, can you please confirm if the following tables already exist on your WordPress database:
    wp_yoast_indexable, wp_yoast_indexable_hierarchy, wp_yoast_migrations and wp_yoast_primary_term.

    If the tables exist, they have been created and there is a different issue. Can you please try the following?:
    1. Install & activate the Yoast Test Helper plugin: https://wordpress.org/plugins/yoast-test-helper/
    2. Go to Tools -> Yoast Test
    3. Locate the Yoast SEO section and select the “Reset indexables tables & migrations” button
    4. Click the “Click here to speed up your site now” button in the SEO->Tools section.

    @ericchen642 @rfischmann :
    Your issues are different, but trying the instructions above should help as well.
    If the problems persist, please create a separate thread.

    @qlm95:
    Your issue is also different. It’s related to your database settings. The problem is that utf8mb4_unicode_ci is not a charset but a collation. The charset should be utf8mb4 in your case, and the collation utf8mb4_unicode_ci. You’re experiencing a similar issue to this one: https://wordpress.org/support/topic/yoast-seo-was-unable-to-create-the-database-tables-required-and-as-such-will-not-6/

    Please check the thread above for a solution. If the problem is not solved can you please create a new forum thread?

    Erich

    (@erichboileau)

    @marcanor It looks like the Yoast Test Helper plugin steps solved my problem! Thank you so much!

    – Erich

    Didn’t know I’d have to go through this all over again… it takes quite a few hours, in my case: https://d.pr/i/9rwVn3

    ericchen642

    (@ericchen642)

    @marcanor Your suggestion didn’t solve my problem. However, I found my only 2 table of wp_yoast_indexable and wp_yoast_migrations in database were empty. Therefore, I just removed them. After that, I de-Activated and then Activated the Yoast SEO plugin. All tables were created correctly, so there is no issue now. Anyway, thanks for your help.

    Plugin Support devnihil

    (@devnihil)

    @ericchen642 @erichboileau Thanks for confirming that your issue has been resolved.

    @rfischmann We’re sorry to hear you are still experiencing problems. For sites with more than 10,000 posts, we advise using the WP CLI command to do the indexation on the server. You can read more about this here: https://yoa.st/wp-cli-index

    If you are familiar with the WordPress Command Line Interface (WP-CLI) you can follow this guide.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘I keep getting Yoast SEO had problems creating the database tables’ is closed to new replies.