WordPress.org

Forums

WP Statistics
[resolved] I keep getting errors! (7 posts)

  1. Dastis1979
    Member
    Posted 9 months ago #

    Table plugin does not exist! Please disable and re-enable the plugin.Why is that and do you know how I correct it?!Also I have this message permanently at the top of my dashboard and I have no need for the option in the plugin, how do I remove it?! - GeoIP collection is not active! Please go to Setting page _ GeoIP and enable this feature (GeoIP can detect the visitors country)

    https://wordpress.org/plugins/wp-statistics/

  2. Greg Ross
    Member
    Plugin Author

    Posted 9 months ago #

    The table error occurs when the database tables do not exist, check your MySQL server to see if they were created properly when you installed the plugin (there should be 5 tables; wp_statistics_useronline, wp_statistics_visit, wp_statistics_visitor, wp_statistics_exclusions and wp_statistics_pages).

    If they don't exist for some reason try disabling the plugin and re-enabling it. If they still don't exist you can manually create them, the definitions are in the install.php file included with the plugin.

    If you don't want to see the GeoIP message, go to Statistics->Settings. Scroll down to the Misc. section and check "Hide admin notices about non active features".

  3. Greg Ross
    Member
    Plugin Author

    Posted 9 months ago #

    Closing due to inactivity.

  4. Dastis1979
    Member
    Posted 9 months ago #

    Hi

    Please don't close it just yet.

    I have been on holiday and just returned yesterday. I'll have a look at your suggestions and get back to you.

    Many thanks

    Dan

  5. Greg Ross
    Member
    Plugin Author

    Posted 9 months ago #

    No problem, we will still respond to the thread, let me know what you find.

  6. Dastis1979
    Member
    Posted 9 months ago #

    Hi

    The tables are all there and I have disabled and re-enabled it a numbr of times with the same issue. It works when I do that but the following day it has happened again.

    I found the tick box to turn off the notifications thanks.

    Any ideas on the crashing issue. Its new installation.

    Cheers

    Dan

  7. Greg Ross
    Member
    Plugin Author

    Posted 9 months ago #

    What is the exact error your getting?

    Is perhaps your SQL server resetting the permissions on the tables?

Reply

You must log in to post.

About this Plugin

  • WP Statistics
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.