Support » How-To and Troubleshooting » I have no admin toolbar.

I have no admin toolbar.

  • My websites were created after 3.4.2 was released. I have never had to update WP on my sites. The first problem I noticed is that under plugins I have no add new option. I have to add all plugins via my cPanel manually. I can get it done but the add new would be so nice. I added the WP policies plugin but cannot get into settings because I do not have the necessary permissions. As I was searching through the forum for a possible solution, I stated seeing posts that users had lost the admin toolbar after updating to 3.4.2. I saw some very complicated (for me) fixes that seemed to work for some users but I don’t have to knowledge to attempt changing php code. I then found a plugin to download the admin toolbar for versions up to 3.4.2. I successfully downloaded and extracted it but can’t see anything different on WP. Selecting admin on the Howdy dropdown just takes me to my profile page. Is the admin toolbar the same as the user toolbar but with more options or one that’s completely separate. I am the only user for my websites and am the administrator yet I don’t seem to have permissions to do some things. Can anyone help this newbie?

Viewing 15 replies - 31 through 45 (of 76 total)
  • tcideas0, can you take a screen shot of your plugins folder?



    Forum Moderator

    you can’t simply change the plugin folder name to deactivate them

    Yes, you can – for all but the most vampiric plugins. See resetting the plugins folder. In especially bad cases, a Phpmyadmin reset may also be needed.

    He asked if I could look at it

    Then I would suggest that the OP hires someone to carry out the work on his behalf.

    I do this for a living

    You are far from the only professional around here. And most of us appreciate the potential danger in handing out admin access to a random stranger on a public forum. For that reason (amongst others). we do not encourage taking support issues off the forum except in cases where a poster is looking for commercial services.



    Forum Moderator

    @tcideas0: Can you use FTP? Or whatever file management application your host provides? I would strongly advice you to learn to use FTP if you intend to run a successful multisite WordPress install. It’s the kind of skill that every site owner should have.

    You are far from the only professional around here.

    I never said otherwise, I was just trying to say I appreciate the risk in doing so. However, as a professional, if someone asks for my help I am inclined to give it.

    At any rate, I don’t want to argue about this. I am just trying to help someone who doesn’t know what they are doing gain a little knowledge.

    @tcideas0: I’ve clearly offended the natives so I’ll bow out of this thread. If you can’t find any help, feel free to contact me directly. You have my email address in your user database, or I can also be found online fairly easily.

    good luck.

    Thank you kristinachilds.

    Esmi, I have used cPanel which I believe is the FTP for Purely Hosting. I ahve had to use it to add plugins because I have no add new plugin option in my dashboard of WP. I have learned a lot and will continue to add to my knowledge. I am going to copy all my posts to MSWord so I won’t loose them. I will reset all 5 themes to 2011. What about the permissions question? Could that be my problem?

    esmi, I have copied all my posts (just in case). I changed all 5 themes to 2011. I deactivated all plugins in WP. In myphpadmin, the value of active_plugins in a:0:{}. I still have no add new plugin option. My use role is administrator. Perhaps my confusion about the adm bar is because I have not used an version of WP earlier than 3.4.2. From what I read the adm bar is combined in the navigation bar on the left. With all the plugins deactivated, I see no actions I cannot take except the options under theme. I can customize and everything else but the “options” button is grayed out. Since I can’t select options, I’m not getting the forbidden message. Am I now at the point where I need to take you last suggestion (- re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.) I’m still wondering about the permissions value in my cPanel. Does that make any difference?

    esmi, have I lost you? Is there anyone who can help me with this problem?

    Do a printscreen and upload it on http://www.speedyshare.com/ or something to share in this forum to view what is the problem

    An image is better than 1000words to explain the pb

    I have tried dragging the screen shot into this box but that doesn’t work. Unless I can email it to you, I can post it as a new post on my website at http://www.ideas-from-toni.biz.

    OK I went to speedyshare. http://speedy.sh/sAGWC/Untitled.png
    Did I do it right?

    I don’t subscribe to speedyshare. I tried the links it gave but they take me to the website but what then?

    try to install a plugin like “user-role-editor” and try to activate the permissions for one new role or one by default

    Have you tried to create a new user with admin rights and to login with this user ?

    No one has suggested that yet. I am trying to sent the screen shot to WP and have it ready to send to this post. Do I use the forum link?

    Could you try to access to this page :


    I have already seen your printscreen .

Viewing 15 replies - 31 through 45 (of 76 total)
  • The topic ‘I have no admin toolbar.’ is closed to new replies.