Support » Fixing WordPress » I have messed up my comments. (form only, no comments)

  • Resolved giant slayer


    I tried using the facebook comments for a while with little success. I have tried to restore the default comments back to my wordpress site.

    For some reason the comments are not being displayed. The comment box for leaving a comment is visible and people can leave a comment, but the comments are not showing up.

    I have copied the comments.php from the 2011 theme and have comments enabled in the admin section. Does anyone have any clue what I might have done? The code for my comments.php is at the bottom of the post. Here is a link to an image I know has a comment.


    [Code moderated as per the Forum Rules. Please use the pastebin]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Anthony


    Your comments.php is identical to a working copy I am currently using. Have you tried replacing your WordPress files?(please backup first) maybe the problem is there.

    I have not tried replacing them. For whatever reason, it appears that something is stopping or blocking wp_list_comments from executing. I checked my functions file and found no functions related to anything dealing with comments.

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Ok, so I deactivated all the plugins and the comments never showed. I tried the 2011 theme and the comments were present. Where might I look within my theme to find what would cause the comments to not be visible while the the comment form is visible?

    Does your single.php file use <?php wp_list_comments();?>?

    No, not in the single.php, but it is in the comments.php
    I think I may have found the problem.

    No, I did not find what is going on.

    I got a little closer. My post is now seeing that there is two comments, but when it goes to list the comments, the following error is given.

    Warning: call_user_func(twentyeleven_comment) []: First argument is expected to be a valid callback in /home/content/g/i/a/giantslayer/html/wp-includes/comment-template.php on line 1334

    I got it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘I have messed up my comments. (form only, no comments)’ is closed to new replies.