Support » Plugin: Server IP & Memory Usage Display » I have a negative RAM

  • Resolved Foxhounds

    (@foxhounds)


    Hi all

    I am experience something strange: I have a -1 MB memory limit, but next to it it says “256 M”.

    80.5 of -1 MB (-8050%) | WP-LIMIT: 256 MB |

    But my php ini says everything is positive, you can view php ini here: https://www.cisema.com/phpinfo.php our Webhosting provider doesn’t help.

    Maybe you can have a look, this would be awesome, thank you so much

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author apasionados

    (@apasionados)

    Hi @foxhounds,

    We get the used memory with the standard ini_get('memory_limit') function. According to your phpinfo information the displayed information should be memory_limit = 512M and not -1 MB.

    It’s difficult for us to trace the source of the error as there are so many different hosting environments. On our side we have not been able to reproduce your error and it’s looks strange as we use a standard function to retrieve the available memory.

    On the other side, the second value has nothing to do with the phpinfo information as we get it from the WordPress options that are configured in the wp-config.php file. Here is some more oficial information about this: Editing wp-config.php.

    Sorry that we can’t help you this time.

    Best regards from Spain.

    Plugin Author apasionados

    (@apasionados)

    We forgot to mention that it would be a good idea to remove the phpinfo.php file from your server because it displays information which can be used to compromise the server that your site is running on.

    Best regards from Spain.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.