WordPress.org

Forums

Quick Cache (Speed Without Compromise)
[resolved] I had to give up on Quick Cache (7 posts)

  1. bassicsax
    Member
    Posted 1 year ago #

    Quick Cache Version 140605.1

    I have been using Quick Cache for nearly 2 years now, and have relied on it to keep my very large site (1838 posts, 14 pages, & 4657 legit comments) running quickly. However, ever since the last QC update, I have been getting nothing but 500 errors when I try and write a post, or delete spam. It took me quite some time to figure out that it was indeed QC that was causing the problems. As a matter of fact, I had phoned my hosting company numerous times over the course of 3 weeks trying to find out what the problem was.

    In the end however, I started to notice a pattern though. Whenever I attempted to save changes to an article that I was writing, there was a message at the top of my post that QC had detected changes to my home page, post page, author page, category archive, and all my tag archives. These messages were new, since the previous version of QC did not show them.

    I understand now that I can't turn off these features in the LITE version that I'm using, so out of desperation, I turned off QC to see if it would solve the 500 server error problems. It did. Not only can I write and save posts again, but I can also delete large numbers of spam without difficulties.

    It seems that QC LITE might work well for smaller sites, but perhaps the newest version no longer works for large sites like mine. Or is this some plugin conflict? Whatever the case, I can't afford to turn it on for the blog portion of my site.

    I just wanted to bring this to your attention. I don't know if anyone has mentioned this to you already.

    The site in question is: http://bassic-sax.info/blog

    https://wordpress.org/plugins/quick-cache/

  2. raamdev
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    I'm so sorry to hear about all the trouble you're having. :(

    In the end however, I started to notice a pattern though. Whenever I attempted to save changes to an article that I was writing, there was a message at the top of my post that QC had detected changes to my home page, post page, author page, category archive, and all my tag archives. These messages were new, since the previous version of QC did not show them.

    Quick Cache LITE always purged several relevant cache files in the background. One of the newer releases added additional Dashboard notifications to indicate what was happening in the background, so much of actual function isn't new.

    What is new, however, are several new routines for purging cache files that should have been purged, but were not being purged, namely cache files related to category and tag archive views, and author page views associated with the post being updated. Quick Cache v140605.1 added that new functionality.

    There were a few bugs in v140605.1 related to those new features, which have been ironed out and fixed in the latest release (v140725, released a few days ago). Please see the changelog.

    We have many site owners with very large sites running Quick Cache (LITE and Pro). My personal site has about the same number of posts and comments as yours and I've been running Quick Cache on it for the past few years as well.

    Quick Cache is designed with large sites in mind, so if you're experiencing a problem I'd love to hear about it and work with you to resolve the issue.

    Could you please try the latest version and let me know if you're still having issues?

  3. bassicsax
    Member
    Posted 1 year ago #

    Thank you very much for your reply Raam, and for all the work you put into Quick Cache. I did notice the update to QC, but was hoping for a reply before I updated it. I will try it and let you know how it goes.

  4. jy33
    Member
    Posted 1 year ago #

    Hi, I think I got recently a similar issue when I update a post : blank result and also 500 server error when I want to see the page.
    I think since 140605.1 and also with latest upgrade v140725.

    LOGGING ERROR :
    The wp-admin has an error.log that contains a quick-cache error with the following backtrace:

    [29-Jul-2014 20:14:21 UTC] PHP Fatal error: Uncaught exception 'InvalidArgumentException' with message 'RegexIterator::__construct(): Unknown modifier 't'' in XXX/wp-content/plugins/quick-cache/includes/share.php:918
    Stack trace:
    #0 XXX/wp-content/plugins/quick-cache/includes/share.php(918): RegexIterator->__construct(Object(RecursiveIteratorIterator), '/^\/home\/jeany...', 0, 1)
    #1 XXX/wp-content/plugins/quick-cache/quick-cache.inc.php(1069): quick_cache\share->dir_regex_iteration('/home/XXX/...', '/^\/home\/XXX...')
    #2 XXX/wp-content/plugins/quick-cache/quick-cache.inc.php(973): quick_cache\plugin->auto_purge_xml_sitemaps_cache()
    #3 [internal function]: quick_cache\plugin->auto_purge_post_cache(26)
    #4 XXX/wp-includes/plugin.php(470): call_user_func_array(Array, Array)
    #5 XXX/wp-includes/post.php(5315): do_action('clean_post_cach...', 26, Object(WP_Post))
    #6 XXX/wp- in XXX/wp-content/plugins/quick-cache/includes/share.php on line 918

  5. raamdev
    Member
    Plugin Author

    Posted 1 year ago #

    @jy33 I have not been able to recreate that issue with v140725. If you're able to reproduce the error, please open a new support thread and include a list of steps for me to reproduce the error. Thank you.

  6. bassicsax
    Member
    Posted 1 year ago #

    Hello Raam.

    Well good news. I have updated Quick Cache, and my problems seem to be solved. I can update posts, delete multiple Spam comments, and apparently do anything else I need to do on my site, without producing 500 errors.

    Thank you for fixing the Quick Cache plugin. It really is a great tool, and I had come to rely on it. I'm now going to update the rest of my sites (all smaller ones). I assume that everything will go well.

    If I have any further problems, it's nice to know that as the author, you do respond to serious issues.

    Thanks again!... helen

  7. raamdev
    Member
    Plugin Author

    Posted 1 year ago #

    Helen,

    I'm so happy to hear things are working well. :) Please do open a new support request if you discover any other issues.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Quick Cache (Speed Without Compromise)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.