WordPress.org

Support

Support » Multisite » i got some new problems!!

i got some new problems!!

  • theboy1
    Member

    @theboy1

    hi.
    my problems:
    1- i did change my vps. i am using kloxo and apache2 .
    problem: blog feeds not found!!(The requested URL /feed/ was not found on this server.) and the not found page(blog.domain.com/any thing) is not wordpress not found page!(it is server not found page(The requested URL /feed/ was not found on this server.))
    i think this got to be than VirtualHost!
    my VirtualHost code in httpd.conf :

    <VirtualHost myip:80>
    ServerName mydomain.com
    ServerAlias *.mydomain.com
    DocumentRoot /home/admin/domaindir
    DirectoryIndex index.php index.html index.shtml index.htm default.htm Default.aspx Default.asp index.pl
    #ScriptAlias /awstats/ /home/kloxo/httpd/awstats/wwwroot/cgi-bin/
    #SuexecUserGroup root root
    </VirtualHost>

    i also tried this code:

    <VirtualHost myip:80>
    ServerName mydomain.com
    ServerAlias *.mydomain.com
    DocumentRoot /home/admin/domaindir
    DirectoryIndex index.php index.html index.shtml index.htm default.htm Default.aspx Default.asp index.pl
    ScriptAlias /awstats/ /home/kloxo/httpd/awstats/wwwroot/cgi-bin/
    SuexecUserGroup root root
    </VirtualHost>

    but withe editing the code some times i see kloxo ip page in blogs.

    But there isn’t any problem on domain.com! even feed is working! the problem is just about blogs(blog.domain.com).

    2- i have asked this before but i couldn’t get the answer!(because i a’m not a englishe one)
    is there any way to let visitors signup in each blog(every blog have users just for it self not for all of network!)?
    looks:
    i signed up in: wpmu.domain.com (and i a’m logged in as a user)
    but i am just a visitor in: wordpmu.domain.com (and must signup to see more!)

Viewing 14 replies - 1 through 14 (of 14 total)
  • is there any way to let visitors signup in each blog(every blog have users just for it self not for all of network!)?

    http://wordpress.org/extend/plugins/multisite-user-management/

    But there isn’t any problem on domain.com! even feed is working! the problem is just about blogs(blog.domain.com).

    Does any aspect of your subdomain work?

    This is really an apache question, and one you should be asking your webhost if you don’t know how to make subdomains (or wild card subdomains)

    theboy1
    Member

    @theboy1

    the blog are ok!(blog.domain.com)
    but the rss feed not found(blog.domain.com/rss)

    i did unistall apache and install it again but this not answer!

    Did you turn on RSS for that sub-blog?

    theboy1
    Member

    @theboy1

    i am not talking about one blog! all blogs got this problem!
    also some page wiche haven’t any post show that eror!(The requested URL /feed/ was not found on this server.)

    but normaly this must show wordpress theme not found page!

    Understand that I’m flying blind here.

    I can’t see your site, so I don’t know exactly what you did and didn’t know, and I can’t even see your error messages.

    All I can give is relative advice.

    1) Make sure pretty permalinks are on, and work, for your main site.
    2) Go turn them on for sub-sites.
    3) Make sure FEEDS are on.

    If everything is redirecting to your feed URL, you messed something up in a theme or plugin, yank ’em all out.

    theboy1
    Member

    @theboy1

    ooo!
    i fix it!
    just i choose the default ip from kloxo panel!

    thanks again, you’re the best 😉
    ok, forgive this problem.

    the other problem! : you did gave me this link:
    http://wordpress.org/extend/plugins/multisite-user-management/
    but this plugin isn’t what i want! i want to each blog be like a site!
    i mean visitorts can register in blogs. if i go to “blog.domain.com/wp-signup” it will redirect to “domain.com/wp-signup.php” i don’t want this happen!(o,man it is too bad if you don’t know engelish language complatly! 🙂 )

    abhishek kuashik
    Member

    @abhishek-kuashik

    i am also facing some problem….
    when i map my domain my domains are automatically to primary domain
    i am wordpress domain mapping plugin for the WordPress Multisite on localhost

    kaushik – Make your own topic, please.

    theboy1 – If you want PER-site registration, please read http://halfelf.org/2012/multisite-registration/

    theboy1
    Member

    @theboy1

    yes i want per site registration but not like this!

    let me tell more about what i need:
    just think we haven’t enable wp network in our wordpress site!(and we are using just WordPress(not WPMU))!
    users can register in our site for read more or see download page and…
    i want to each site be like it!(users register but not for a blog! just for see the links or….)
    you got it?
    sorry,i can’t talk english better.

    I’m sorry, I don’t understand what you want.

    If you’re not using Multisite (it’s nto WPMU anymore) then how do you know what we’ve suggested isn’t right?

    You want users to be able to register to read content and download: That’s just basic membership plugins.

    You want all subsites to act the same way, where users have to register to read content? Again, that’s a basic membership plugin.

    Install Multisite, add the plugin and activate it per blog.

    theboy1
    Member

    @theboy1

    You want all subsites to act the same way, where users have to register to read content? Again, that’s a basic membership plugin.

    Install Multisite, add the plugin and activate it per blog.

    That’s what i want! which plugin i have to activate to all blog?

    theboy1
    Member

    @theboy1

    good good good!
    thank you for the best support!
    tnx again.

    theboy1
    Member

    @theboy1

    ooo!
    got problem again!

    i was using cet_blogs_defaults plugin.
    any blog which registered when this plugin was active don’t show feed!(looks like feed is disable!)
    how can i enable this?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘i got some new problems!!’ is closed to new replies.