Support » Requests and Feedback » I got a http error when uploading images

  • I got a http error when I am uploading a image with a long name and there are some spaces and special characters in the name.

    Is that y it’s not working, is there any thing I need to do to fix this problem?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Are you using a web hosting account with Unix, Linux or the like? If so, filenames cannot have spaces in them:


    Not correct:
    file name.jpg

    As well, some characters are reserved for use by the server; try taking those out as well and see if it works.

    Thanks for the reply

    and yes it is a Linux server.

    Okay. So Linux servers, which typically use the Apache web server software, do not play well with spaces in file names. In short, there CANNOT be spaces in the names of your files. Apache typically replaces them, as such:

    file name.jpg

    But, since there is no file%20name.jpg, that causes a problem.

    Just ensure that your files don’t have spaces in the file names (and I’d suggest not using any special characters that cause problems), and that should do it.

    my wife’s blog has exactly the same problem — it’s a fresh install of 2.5.1. There are no spaces or special characters in the filenames. It’s also on a linux server. I’m going to try reinstalling in case some files didn’t get uploaded.

    My blog is having the same problem. None of the file names have spaces or strange characters. I’ve even tried cropping and resizing and renaming to see if it made a difference, but I still get the HTTP error when WordPress starts “Crunching” the downloaded file. At that point all I can do is click on “dismiss” when it tells me “An error has occurred in the upload. Please try again later.”

    Is there a permission I need to change or something within the database that could be causing this error?

    Fixed it in my wife’s blog (mine wasn’t affected) by installing this plugin. It’s mentioned in Otto’s sticky in the How-To forum.

    It seems to be only on smaller images that I get the http error. I can upload a large image, but it won’t post to the page. I tried the plugin and I’m able to upload the smaller images now, but still can’t post the image to the page.

    no plugins required, no namechanges, and no file reduction.

    “The solution for me was to edit the .htaccess file in the root directory of my webserver (the directory where WordPress is installed). Add the following to the the .htaccess file after the “END WordPress”:

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    If you are having the problem of your .htaccess file losing its changes, you have most likely put something inside the WordPress block of the .htaccess file. Keep any custom changes outside of that block or they will be overwritten.”

    Compliments of:

    Thanks it helped

    yeah thanks, the .htaccess fix worked the best.

    Thx Haecceity,
    I was tring to short it out from las 1 hr, but your, small link to big problem helped a lot for me.Thx for the link man.

    if any body have this http error then they should blindly use this no flash upload plugin.
    Thx again


    Where do you upload the No Flash upload file to?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘I got a http error when uploading images’ is closed to new replies.