Support » Fixing WordPress » I Give Up – Connection lost error HAS NOT BEEN RESOLVED!!!!!

  • Regardless of where I ask this question the only answer that is ever received is:

    please start your own thread per:

    Closing this because the issue was resolved for the OP.

    Great, except most of the people that I know that claim to have resolved this “INTERMITTENT” problem haven’t really resolved it, they have merely not had it occur for a brief period of time.

    This is an Intermittent problem and it is therefore impossible to declare it resolved in any small window of time. I have gone periods without having this error come up, and I have had it come up fairly frequently with no document-able reason for it.

    This problem did not exist at all prior to the wordpress 3.6 updates..

    So, let me re-post my message, in a new thread as ordered, and oen that I hope will remain open until an actual explanation for the problem and a resolution are forthcoming…

    Common Error Message:Connection lost. Saving has been disabled until you’re reconnected. We’re backing up this post in your browser, just in case.
    Common Problem… perhaps system wide…
    Okay, so now we have been told that since every system is different and as a result every problem is different.
    We have been told that there is no system wide fix because there is no system wide problems…
    If that is the case, then please explain why EVERY one of the 500+ word press sites that we own, operate or manage for clients expresses this same, exact error AFTER each was upgraded to WP 3.60?
    We have sites running themes from virtually every theme creator.
    We are running sites using a total of over 300 different plugins, with different groups of plugins in different sites…
    We are running sites on shared hosting accounts, VPS accounts and a variety of different dedicated servers with some using rotating memory and some solid state drives…
    We are using different hosting services from Liquid Web, to network solutions, to GoDaddy, to HostGator, to blue host, to 1&1, and others…
    I can only conclude that if it walks like a duck, sounds like a duck, smells like a duck… then it is probably a duck!!!
    Now instead of telling people to open new threads based on some mis-conceived notion that this is not a system level problem, how about actually looking into the problem and being helpful rather than simply trying so hard to sweep this huge and growing problem under the rug in typical sysadmin style???
    We are wasting HOURS every week screwing around waiting for this stupid issue to resolve itself so that we can proceed with our work.
    Don’t you get it, YOUR credibility is at stake on this issue, not mine!!!

Viewing 12 replies - 1 through 12 (of 12 total)
  • most of the people that I know that claim to have resolved this “INTERMITTENT” problem haven’t really resolved it

    Doesn’t matter. You should still post your own topics.

    With regard to your problems, they seem to be specific to your sites. No one else is suffering the same problems to this extent. Last I checked, just prior to the release of WP 3.8, WordPress 3.7.1 had well over 10 million users. Yet there has been no mass influx of users reporting these problems.

    I would suggest that you start trying to resolve these on a per-site basis as you may be looking at a whole range of different root causes.

    how about actually looking into the problem and being helpful rather than simply trying so hard to sweep this huge and growing problem under the rug in typical sysadmin style???

    No one is sweeping anything under any rug. I suggest you review the Forum_Welcome and learn how these forums work as this explains – quite clearly – why you were told to post your own topic in the older thread you attempted to hijack a few hours ago.

    instead of telling people to open new threads based on some mis-conceived notion that this is not a system level problem

    If you learn how to use these forums correctly, you will find that the posting process is so much easier.

    YOUR credibility is at stake on this issue

    Sorry? Whose credibility? WordPress is an application – not a person, an organisation or a team. The application is developed by a huge community of unpaid developers. The site distributes and documents the WordPress application but has no connection with any site running that software.



    I kind of hate adding to this thread, given the attitude of the OP, but I am seeing this issue on a customer who recently upgraded to 3.8. Here are her symptoms:

    “I am having some issues with uploading pictures into my media. My internet is fine, but when I try to upload pictures I get this message: Connection lost. Saving has been disabled until you’re reconnected. We’re backing up this post in your browser, just in case.

    “Do you have any idea what this could be? Is it something to do with the new WP update? Also, sometimes my site is very slow to load for me.”

    From the administrative side, I am getting dozens of “excessive resource consumption” notifications for her account from lfd/csf:

    Time: Sat Jan 18 14:56:20 2014 -0500
    Account: thehumbl
    Resource: Process Time
    Exceeded: 1809 > 1800 (seconds)
    Executable: /usr/bin/php
    Command Line: /usr/bin/php /home/thehumbl/public_html/wp-admin/admin-ajax.php
    PID: 24121 (Parent PID:23326)
    Killed: No

    Time: Sat Jan 18 14:57:20 2014 -0500
    Account: thehumbl
    Resource: Process Time
    Exceeded: 1854 > 1800 (seconds)
    Executable: /usr/bin/php
    Command Line: /usr/bin/php /home/thehumbl/public_html/wp-admin/edit.php
    PID: 24191 (Parent PID:24016)
    Killed: No

    System information:
    CentOS release 6.5 (Final)
    PHP 5.3.23 (cli) (built: Apr 6 2013 10:50:05)
    Server version: Apache/2.2.24 (Unix)

    We are using suPHP as our PHP handler, are using ModSec with the Atomic ruleset, and are a cPanel host. If you require any additional information, I’d be happy to provide it.

    I very much appreciate the time and effort you all put into WordPress to make it such an amazing platform – keep up the good work! 🙂



    Hi there –

    More bits of data, if they’ll help: Her most recent save attempt triggered these warnings:

    Time: Sat Jan 18 15:50:21 2014 -0500
    Account: thehumbl
    Process Count: 11 (Not killed)

    Process Information:

    User:thehumbl PID:12255 PPID:12128 Run Time:606(secs) Memory:173920(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/index.php
    User:thehumbl PID:12285 PPID:12264 Run Time:601(secs) Memory:149468(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/wp-admin/admin-ajax.php
    User:thehumbl PID:12414 PPID:11636 Run Time:571(secs) Memory:149468(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/wp-admin/admin-ajax.php
    User:thehumbl PID:12492 PPID:12435 Run Time:557(secs) Memory:149984(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/wp-admin/plugins.php
    User:thehumbl PID:12755 PPID:12738 Run Time:498(secs) Memory:149468(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/wp-admin/admin-ajax.php
    User:thehumbl PID:13123 PPID:12259 Run Time:409(secs) Memory:149984(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/wp-admin/plugins.php
    User:thehumbl PID:13177 PPID:13119 Run Time:388(secs) Memory:149696(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/wp-admin/admin-ajax.php
    User:thehumbl PID:13183 PPID:13182 Run Time:386(secs) Memory:148944(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/index.php
    User:thehumbl PID:14756 PPID:14339 Run Time:38(secs) Memory:148944(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/index.php
    User:thehumbl PID:14921 PPID:14615 Run Time:6(secs) Memory:148944(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/index.php
    User:thehumbl PID:14949 PPID:11776 Run Time:0(secs) Memory:170648(kb) exe:/usr/bin/php cmd:/usr/bin/php /home/thehumbl/public_html/index.php



    So sorry to be spamming up this post, but it looks like more folks are reporting it in other areas now. I’ve downgraded my customer above from 3.8 to 3.7, which resolved the issue of being unable to save her posts without the timeout error. However, she was still unable to upload photos. This ended up being ModSecurity rule being tripped, which I had to whitelist on the async-upload.php file.

    Other folks may be running into a similar ModSec issue, which would not be visible to end-users – only their systems administrators. For sysadmins to find it, grep for your customer’s IP address in the Apache error log and see what rule is being tripped, then edit your whitelist to exclude, if possible.

    Hope this helps!

    Moderator kmessinger


    I know you are trying to help but it really would be better to start your own thread. Also it is much better to include a url for the site having the problem.

    @ Erin – I think the OP’s attitude is just sounding this way out of frustration. I have to agree with this frustration except the part about throwing all sysadmins under the bus. HeeeeyNooooow!

    I get that the mods are just trying to enforce the rules about starting your own thread which is ideal most of the time, but when there is a problem that seems to be affecting so many installations, I think it actually helps to allow the community (we are a community, right?) to come together to post their hosts, settings, plugins, themes, etc., in combined threads so we can work together in finding the common problem. Single threads work for single problems, but there seems to be a lot of users affected by this, and I’m not just talking about posts on WP, but other sites as well. I think there may not be as much reporting because it’s more of a horrible inconvenience instead of a showstopper and doesn’t effect the front end of the site. JMO

    Many of us that are still experiencing this issue on multiple, completely differently configured sites have NOT posted at WP in hopes of figuring the issue out ourselves. Unfortunately in my searches I find many posts similar to how the OP described where it’s not truly resolved, or the user downgraded WP to “resolve” it.

    I love WordPress, but something is not right here. I am not a developer, but the link does seem to be WordPress, or something written in WordPress that is affecting a multitude of plugins and themes and not just one or two.

    Just my two cents.

    I feel you, OP. I switched hosts, upgraded to latest version, deleted most of the plugins, switched to default theme, deleted whole installation and started from scratch and issue still persists which leads me to believe it might be related to Multisite (which I am using).

    I know that people will reply with “start your own thread” but at this point is, well, pointless. I am just tired of seeing the “Thank you for Updating! Please visit the Update Network page to update all your sites.” whenever the connection times out.

    Anyway, no need to reply my message. Just wanted to write this and share my pain. 🙂

    We have some of the top techs at our hosting service working on this now as well as our own in house staff…

    Here are some notes regarding this from those onsite techs…

    02.04.2014 08:25am Robert Benschoter Systems Administrator

    After looking things over, it looks like there is a problem between the site and MYSQL when this error is present. I have a found a fairly consistent way to reproduce the error. It seems that the initial publishing of works fine.

    The problem seems to be on the first update to the post that causes the error. From the backend it looks like wordpress reissues the queries over and over again until one completes. This spawns a couple dozen queries at times. From my investigating it looks like this may be caused by something implemented in wordpress 3.6 called the heartbeat API.

    I have found threads that show how this can be disabled, however it looks like it would also disable the auto save feature within your posts. There are a number of alterations to the posting interface by plugins. The only way i see to narrow this down any further would be to disable all of the plugins, and possibly the theme, to see what is affecting this process. Please let me know if you have any problems with me doing this.

    02.05.2014 04:42am Nate S. Systems Administrator

    I have actually been seeing this happen more frequently with WordPress 3.6 and 3.5, but not so much with versions newer than that. I suspect WordPress may have changed how the procedure is performed in one of these versions causing the sudden appearance of this vague error.

    The autosave feature for WordPress defaults to saving every 2 minutes. This can be set in the wp-config.php file, which I’ve done temporarily and set it to 10 seconds in hopes of replicating the issue.Luckily I was able to replicate the issue, and as suspected, this is happening when mysql is utilizing all of its available connections.

    I was only able to replicate this though by simulating a large amount of traffic to your server. Once done, I began seeing the issue occur with a new draft I created titled “lwtest1”.Currently the max connections for mysql is set to 200 and this can be raised if you’d like.

    I’d suggest that we first try increasing it to 250 and see how well this works out. Unfortunately my test was also a little skewed though. I was pushing a high number of concurrent requests to this particular site in a short period of time, and I’m certain if I raise the max connections for mysql to 250 and do the same test that it will happen again.

    However during “normal” traffic times, 250 may actually suffice.

    Alternatively, if you’d like to get a more accurate idea of the max connections mysql is using historically, we can let it run as is for a few days then check it again to see if this was hit. If it was, then we can likely confirm this is the issue and increase it. Though if this isn’t hit and you still see the problem happening, then we’re likely looking at something else.

    I’d like to chime in here with yet another thing to check which seems to be overlooked in most of the discussions I’ve read, namely, the default setting for WP_MEMORY_LIMIT, which is 40MB for non-Multisite configurations and 64MB for Multisite. Both of these values can be quite constrained, depending upon a number of factors (content, theme, plugins, etc.).

    Perhaps [Link redacted – please keep support within these forums] on this from last June may shed some light. I’d actually forgotten this issue, and have been battling with stalled connections, overall slow response, and all of the frustration which accompanies such things. I bumped the limit on the particular site which has been confounding me, and it feels like a weight has been lifted (or someone took off the lead boots!).

    Lewis Rosenthal: Can you post the contents of the post here so we can see the suggested fix…seems you were redacted…this is a terrible issue…hundreds of people upset and posts just keep getting closed without resolution…

    Unbelievable… Well, it’s Automattic’s site; they may dictate the content available on it. That’s why I have my own blog in the first place, so that others can’t tell me what I can and cannot post.

    If you click my name, above, you will get to my blog. Once there, search for “WP_MEMORY_LIMIT” and you should come up with a post of mine from last June, which describes where changes need to be made to increase the memory limit.

    I’m still shaking my head over this one… Thanks for bringing it to my attention.



    PS – If for some reason, clicking my name doesn’t work (it looks like it’s working from here), find the plugin page here for WP post to PDF Enhanced; that’s mine, and you can find links to my blog there.

    Lewis Rosenthal: check your site! may have problem!!

    Error establishing a database connection

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘I Give Up – Connection lost error HAS NOT BEEN RESOLVED!!!!!’ is closed to new replies.