• Resolved webiiisitenow

    (@webiiisitenow)


    Hello, I am having an wired issue. I am translating a site with Locotranslate, all is going well but I saw that after a few hours or minutes the second version of German language apears. I have this structure:

    German
    Edit | View | Info | Copy | Move | Delete
    1% 11,572 11,478 woocommerce-de_DE.po 8.4.2024 12:02 pm Custom

    German
    Edit | View | Info | Copy | Move | Delete
    100% 9,115 0 woocommerce-de_DE.po 9.4.2024 9:39 am System

    English (United States)
    Edit | View | Info | Copy | Move | Delete
    .01% 11,572 11,571 woocommerce-en_US.po 5.4.2024 6:51 am System

    I am editing the German Custom – 1% and the one in System it keeps apears. It will not be an issue if it’s just stay there, the issue is that all I translated in Custom is gone as there is nothing translated.

    I do hope somebody understands my issue and makes light in here, thank you!

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Tim W

    (@timwhitlock)

    It’s normal for WordPress to reinstall system translations you’ve removed.

    If custom translations are not being merged on top, then try syncing and saving the custom PO files.

    Thread Starter webiiisitenow

    (@webiiisitenow)

    I have just save/synked the custom file and still the translations are not showing up on site, only way they display is after deleting the sistem language 😕

    Plugin Author Tim W

    (@timwhitlock)

    I need precise steps to reproduce this issue on my system please. Preferably without having to fully set up WooCommerce.

    Thread Starter webiiisitenow

    (@webiiisitenow)

    Doing my best to explain again in detail:

    Upon Locotranslate / Plugins / Woocommerce , language woocommerce-de_DE.po – I used to have English and German custom, I translated all that matter to me, all was fine.

    After a few hours I checked back the site, translations were gone, I went back to locotranslate and saw the 3rd language, a duplicate german language in system path.

    After I delete the system language / this 3rd one that apeared, the tranlsations are back displaying on site correct.

    Is there anything else I would have to give, other specific info ? thank you for your time!

    Plugin Author Tim W

    (@timwhitlock)

    This is not sufficient detail for reproducing a problem.

    Choose an example string in your custom file. Describe how to view this string (translated, in context) on my screen.

    Thread Starter webiiisitenow

    (@webiiisitenow)

    The string “Add to cart” in woocommerce-de_DE.po (custom) file is “Warenkorb”

    The same string “Add to cart” in woocommerce-de_DE.po (system) file is “In den Warenkorb”

    In this scenario, when bouth files custom and system are inside locotranslate, the string on site remains “Add to cart”

    In the scenario, when I delete this file: woocommerce-de_DE.po (system), the string on site will be : “Warenkorb”

    Plugin Author Tim W

    (@timwhitlock)

    This string appears to be referenced in at least 18 different places in WooCommerce. So is “Add to Cart” (with capital C). Finding your exact problem is not possible from your descriptions.

    Do you at least know if the rendering you have a problem with is from the MO file (PHP rendering) or a JSON file (JavaScript rendering)?

    Thread Starter webiiisitenow

    (@webiiisitenow)

    this is how it looks, bouth are .po files, i really do not know why the System german file apear after I delete it, is it possible to block this so that it only remains custom file?

    Plugin Author Tim W

    (@timwhitlock)

    As mentioned previously, it’s normal for WordPress to reinstall missing files. See FAQ: https://localise.biz/wordpress/plugin/faqs/files-deleted

    The above link briefly explains how to prevent auto-updates of translations, but I don’t recommend you do this. You should in fact be using this file as the template for your custom files. See this guide: https://localise.biz/wordpress/plugin/custom-translations

    I am still keen to solve the actual problem of custom translations not working. I just need a specific, and easily reproducible example.

    Thread Starter webiiisitenow

    (@webiiisitenow)

    I am now sure what am I doing wrong 🙁 . Is it suposed to normally have 2 German PO files ? I still cannot translate because the system file keeps apears and it blocks the custom file translations

    Thread Starter webiiisitenow

    (@webiiisitenow)

    What options do I have to permanently stop Locotranslate add the system PO file ?

    Plugin Author Tim W

    (@timwhitlock)

    What options do I have to permanently stop Locotranslate add the system PO file ?

    Loco Translate is not doing this. WordPress is. See the link I’ve already referenced for disabling auto-updates of translations.

    Thread Starter webiiisitenow

    (@webiiisitenow)

    I have read that adding this file it might stop this autoupdate / meaning the system file will not be imported anymore ?

    Source: https://gist.github.com/timwhitlock/8d4d2fa35c0ab312d040223ef6990e5b

    Thread Starter webiiisitenow

    (@webiiisitenow)

    Should I add this inside wp-content / plugins / loco-translate ?

    Plugin Author Tim W

    (@timwhitlock)

    Read the comment. This snippet has nothing to do with Loco Translate. It’s implemented as a plugin.

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.