Support » Plugin: Cleverwise Redirect It » I get nothing!

  • Resolved kenthegargoyle

    (@kenthegargoyle)


    I’ve got my redirectit.php file with 777 permissions in a chmod directory with 777 permissions and redirectit has written to it. This is not my problem.
    My problem is: When I click on “Add Redirect” then type a name in the “Name” box, a destination URL in the “Destination URL” box, with the “On (Standard)” radio button selected, and then click on the “Add” button, I receive a message stating the it has been successfully saved, yet it I try to review it or “Build Redirect File” none of my information has been included.

    https://wordpress.org/plugins/cleverwise-redirect-it/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jeremy O'Connell

    (@cyberws)

    I have seen this before and it is usually a permissions issue. There are some web hosts that don’t allow files to be 777. So assuming the paths are correct I would change the directory permission to 755 and your file to either 644 or 755. Then try rebuilding the file.

    What happened?

    I get the same thing, and it does not appear to be a permissions issue.
    Regardless of what I type in the name field, whether I begin with a ‘/’ or end with a ‘/’ or both or neither (i.e. “shop”, “/shop”, “shop/”. or “/shop/”) and what I use for my destination link, I get the following result:

    <?php
    /*
    Wordpress Plugin Cleverwise Redirect It auto generated file
    Do NOT edit directly as changes will be overwritten by plugin
    Layout: 010114
    */

    $redirects=array();

    $l=’skip’;
    $rourl=’http://gargoylefitness.com’;

    if (isset($_REQUEST[‘l’])) {
    $l=$_REQUEST[‘l’];
    $l=preg_replace(‘/\//’,”,$l);
    }

    if (array_key_exists($l,$redirects)) {
    $rourl=$redirects[$l];
    }

    header(“Location: $rourl”);
    ?>

    It writes the above code. What it’s not doing is inserting my data.

    Plugin Author Jeremy O'Connell

    (@cyberws)

    I just realized the issue and know how to fix it. I updated the database and addressed this for upgrades but not new installs. It will be easy to address. I will get a new version out today.

    I apologize for the error and appreciate you bringing this to my attention.

    Plugin Author Jeremy O'Connell

    (@cyberws)

    Okay I just released version 1.5 which should address this bug. You simply need to install the new version and the plugin should then write out your data.

    You may need to set your permissions back if you altered them.

    Did the new version work for you?

    It’s accepting and correctly displaying my redirects now, but it’s not saving them to the file. The resultant redirectit.php file is still the same as above. (and yes, I verified this by deleting the previous contents of the file. It simply wrote the file, again, exactly as above.)

    Plugin Author Jeremy O'Connell

    (@cyberws)

    I am guessing you are trying to get this plugin going so you don’t have a lot of data. I recommend deleting all data then enter one simple test redirect.

    IE:
    Name: Google
    URL: http://www.google.com/

    You could also uninstall and reinstall the plugin to quickly delete all data, although you, of course, have to reinsert the settings.

    I would suggest deleting the redirectit.php file completely, make sure your directory is 777, and try the creation again. I know, I know you said you deleted all the data but it never hurts to give it a try.

    Now try generating the file. Does that work?

    Plugin Author Jeremy O'Connell

    (@cyberws)

    I wanted to follow up to check on the status of your request.

    To be honest, in trying to sort out the problem, I’ve learned how to code them myself. I never got the plugin to work correctly, so I removed it as I no longer need it.

    Plugin Author Jeremy O'Connell

    (@cyberws)

    I understand. I have marked this topic resolved.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘I get nothing!’ is closed to new replies.