Support » Plugin: Podcast Subscribe Buttons » I get an error on my WordPress page with version 1.2.0

  • Resolved marcbolan

    (@marcbolan)


    Hello,
    I upgraded to version 1.2.0, and I get an error with my dashboard on every page:

    Warning: include_once(/home/customer/www/barbarellavinyls.com/public_html/wp-content/plugins/podcast-subscribe-buttons/includes/CMB2/CMB2/includes/CMB2_Hookup.php): failed to open stream: No such file or directory in /home/customer/www/barbarellavinyls.com/public_html/wp-content/plugins/podcast-subscribe-buttons/includes/CMB2/CMB2/includes/helper-functions.php on line 44
    
    Warning: include_once(): Failed opening '/home/customer/www/MYWEB.com/public_html/wp-content/plugins/podcast-subscribe-buttons/includes/CMB2/CMB2/includes/CMB2_Hookup.php' for inclusion (include_path='/home/customer/www/barbarellavinyls.com/public_html/wp-content/plugins/hookr/inc/../lib/:.:/usr/local/php71/pear') in /home/customer/www/MYWEB.com/public_html/wp-content/plugins/podcast-subscribe-buttons/includes/CMB2/CMB2/includes/helper-functions.php on line 44
    
    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'CMB2_Hookup' not found in /home/customer/www/MYWEBs.com/public_html/wp-includes/class-wp-hook.php on line 288

    If I deactivate the plugin, the error disappears. At this time I have installed the previous version of the plugin, and it works.

    Thanks in advance

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author SecondLineThemes

    (@secondlinethemes)

    Hi there,

    Thanks for using our plugin.

    We’ve included in the latest version of the ‘Podcast Subscribe Buttons’ plugin an update to the CMB2 framework which is included in our plugin.

    Looks like there are a few issues caused by this latest version of CMB2, so we’re rolling back to 2.6.

    So to make long story short – it should be resolved in version 1.2.1 of the Podcast Subscribe Buttons, so feel free to update.

    Ok, I’ll wait for the new version
    Thanks for your quick response.

    Best regards

    I’ve just installed the version 1.2.1

    It works fine again

    Thanks and best regards

    Plugin Author SecondLineThemes

    (@secondlinethemes)

    Great! Thanks for the update.

    @secondlinethemes To fix this with the latest version of CMB2, make sure the includes/CMB2_Hookup.php file in your bundled version is named exactly like that. If you use git to pull down the update, it may not grab the file-name case-change correctly.

    Plugin Author SecondLineThemes

    (@secondlinethemes)

    @jtsternberg – Thanks so much for finding this thread and offering a solution. We can’t thank you enough for CMB2 and have been using it for years, really appreciate your work!

    Anyways, yeah, I figured this could be the case as we used SVN to deploy the update to the WP.org repository. For now the included version is rolled back to 2.6, but we’ll make sure to have some further tests done before updating again to 2.7

    👍

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘I get an error on my WordPress page with version 1.2.0’ is closed to new replies.