Support » Requests and Feedback » I get a fatal warning with Spelling Checker

  • I just installed the coldforged spelling checker. I followed the instructions. And in the options tab, I get 1 blue “note” and 2 red “fatal” warnings.
    (#1)FATAL: The temporary directory you specified is not writeable from the Apache task. Either select a different temporary directory (like “/tmp”) or make the directory you specified writable by the Apache task (chmod 755 the directory).

    I did this.

    (#2) FATAL: You forgot to make the personal dictionary directory writable. Please read the install instructions and chmod this folder to provide write privileges to the Apache task.

    I don’t see the file called “aspell.personal” anywhere. Do I need to make one?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Did you check the plugin author’s website and see if anyone else has reported similar problems to them? Then contact the plugin author for the specific help you need.

    I saw nothing, everyone was praising it. I saw he is here sometimes, coldforged.

    I am having other issues over at another thread now.
    I don’t know if that was how to post the thread address or not.

    Is that the “exact” error message you’re getting? If it is, it’s wrong.

    Is your temp directory 755 or 777? 755 is writable only by the owner of the file/directory.

    If it is, it’s wrong.

    Depends on the install and host… for hosts that run PHP under the user’s UID — as mine does — 0755 is just right.

    That said, for other types of hosts, 0777 may be required. residual, try creating a folder outside of your HTML hierarchy if you have one. For instance, if your web root is at ~/public_html/, create a folder called ~/spell/, chmod it to 0777, and provide the full pathname to that folder for the temporary folder and for the personal dictionary location. That way you reduce the security risks from having a writeable folder in your web-accessible hierarchy.

    The reason you didn’t see the file is because Apache didn’t have permission to create it :).

    Oh and I wouldn’t characterize the comments as “everyone praising it”… there’s 8 mentions of the word “fatal” on that page, and a comment expressly discussing this issue.

    “Depends on the install and host… for hosts that run PHP under the user’s UID — as mine does — 0755 is just right”


    How many hosts actually do this, though?

    I’ve worked with a bunch (for myself and other people)…and, well, as you can see from my first post in this thread, I had never seen this.

    Learn something new everday, eh? 🙂

    Yeah really. Honestly, I assume it’s the exception rather than the rule… but when I wrote the plugin I didn’t put too much thought into the error messages aside from putting something there that would give the user an idea what’s going wrong. Oddly, providing no suggestion probably would have been less confusing than providing that suggestion. Ah well.

    I tried changing the chmod. No diiference.

    I’m gong to try moving it now.

    One thing is I am not even seeing the spell button on the write page yet, I’m guessing that the file has to be there for it to show up.

    Tried moving the file, but still nothing.
    Novice question here: How do I set the path outside of the public folder?
    url/spell/ ?

    Also do I need to change the name and pasth to aspell ?
    & Path to temp files?

    My computer took a time out on me there for a few hours, I still am having no luck.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘I get a fatal warning with Spelling Checker’ is closed to new replies.