Support » Plugin: LiteSpeed Cache » I enable Webp option but its not working

  • Resolved ranaharoon322

    (@ranaharoon322)


    I enable Webp option but its not working but its still showing jpeg and png format am using litespeed plugin please check my url and guide me thanks 🙂

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 25 total)
  • Hi @ranaharoon322, may I know did you run LiteSpeed Cache > Image Optimization to retrieve the webp version of the images?

    yes

    please check my site it still loads png or jpeg not webp

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Please make sure that you have enable webp optimization

    for instance , https://www.creativewoolf.com/wp-content/uploads/2019/02/Okjpg.jpg.webp this result in 404 error , that’s why no webp replacement.

    please check in your file system if webp file exists.

    Best regards,

    how can i check file system?? please guide me

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    If you have control panel , like cPanel or Plesk and such , go to file manager , and navigate to /wp-content/uploads/ folder.

    If you have FTP access , then go to that folder and see if you find any file with name ends with “.webp”

    Best regards,

    hi i see some webp in “03” folder but not any webp in “02” folder and the extensions is looking like that bg-min-1024×356.png.webp only png convert ton webp i think but not jpg

    in the front end its still not converting to webp

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Have you enabled webp at beginning ? or enable it in the middle way of optimization ?

    because if images that were already optimized, it won’t be send and to generate webp version again.

    you will need to destroy all optimized image and re-do the optimization.

    Best regards,

    Hi there,

    I am sorry to jump on your thread @ranaharoon322 But I can confirm I am having the same issue. Everything is enabled, images optimized and I can also see the Webp version on the server. However Webp images are not appearing on the site. The plugin is still serving the old jpg and png files only.

    I would assume there is some kind of bug with the Plugin.

    Kind regards

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    @jacksmithy please enable advance debug log to your IP

    If you see .webp file in your file system but didn’t replace , log should state why

    Best regards,

    Which line you are looking for?

    Also do you want me to: Debug Level basic or advanced?

    Thanks

    I enabled in middle but the problem still exist

    Plugin Support qtwrk

    (@qtwrk)

    @jacksmithy advanced, to your IP , and then purge it , access the home page , check the log, and search for “name of your image file” for example logo.jpg

    @ranaharoon322 please try destroy optimized images and re-optimize it with webp enabled

    Thanks for that.

    I followed your instructions to the latter and all images are png and jpg. Not a single one with Webp extension.

    What is next?

    Kind regards

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘I enable Webp option but its not working’ is closed to new replies.