Support » Plugin: Weekly Class Schedule » I don't see anything in "normal" layout

  • Hi!

    If I use the “normal” layout I don’t see anything in the schedule. In the other hand, if I use the “list” one, everything is working fine.

    I realise in the wcs3_render_normal_schedule function of wcs3_output.php, there’s nothing in the output variable:

    $output .= '<td class="wcs3-cell ' . $css_name . '"></td>';

    But in the wcs3_render_list_schedule function of the same file the output variable make sense:

    $output .= '<li class="wcs3-list-item-class">';
    $output .= wcs3_process_template( $class, $template );
    $output .= '</li>';

    Is all of these correct? What’s wrong?

    Best regards.

    http://wordpress.org/plugins/weekly-class-schedule/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author ty_pwd

    (@ty_pwd)

    Please post a link to the schedule.

    The above code is correct. Normal layout is generated by JavaScript as opposed to the list layout which is generated directly from PHP.

    I’m having the same issue:

    Does not load anything:
    http://www.thomasmacneil.com/#!/calendar/

    Works fine:
    http://www.thomasmacneil.com/calendar/

    Follows what you’re saying that if the normal layout is generated by Javascript and there’s an issue with the loading I’d see this. Thoughts?

    Plugin Author ty_pwd

    (@ty_pwd)

    Interesting…

    Can you please modify line 10 of the file weekly-class-schedule/js/wcs3_front.js to:

    $('.wcs3-schedule-normal-layout:eq(0)').load(function() { (from `$(document).ready(function() {‘) and report back?

    Thanks.

    Done and available for review. That didn’t fix it but the two pages are the same now.

    Plugin Author ty_pwd

    (@ty_pwd)

    Because your theme is all JS, the normal page load events are not being called. Please contact us directly and we can look further into this issue.

    My WordPress is the 3.5.1 version. I installed the 2.0.5 version of Weekly Class Schedule and it’s working.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘I don't see anything in "normal" layout’ is closed to new replies.