Support » Fixing WordPress » I did something to stop the googlebot from coming back

  • Last week I installed

    I assume it is no coincidence that google has not been able to spider my site since then. I just went in google webmaster tools and there are 404 errors for 321 pages. My traffic has fallen off. I uninstalled the plugin this morning and the resubmitted my sitemap but it is still getting an error message that google can’t find my robots.txt file.

    OK, I am clueless and I should not be allowed to operate my own blog :-> Help, please. I have no idea what I am supposed to do to fix this.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Unfortunately, since we can’t read what’s in your .htaccess, it’s difficult to know how to respond.

    I have tried to open that file and it seems to be empty.

    What file are you referring to? The plugin?

    Do you have a robots.txt file?

    I thought I did. But now I can’t find it -robots.txt, I mean

    I tried to open htaccess. I uninstalled the plugin. Now I have made everything worse. Was just writing a new question.

    I don’t know if you’re still around, Maureen. However, a website does not *have* to have a robots.txt file; it’s just there to tell search engines what not to spider.

    While it looks like you’ve fixed your blog, I’d also say that, as to enforcing www/non-www URLs, it’s better to edit the .htaccess file directly than to use a plugin. My guess is that when you uninstalled the plugin, it affected the .htaccess, and so you got problems.

    Anyway, it does look like you’ve fixed it.

    I fixed it but I lost signifcant traffic for some reason. I know you don’t have to have a robots.txt file. I did not have one before I put in the plugin. Googlewebmaster tools was giving me an error message that there is no robots.txt file so I put one in and that resolved the error message and got google to spider again.

    How would I go about hiring someone knowledgeable to look at my .htaccess file to see where the problem is. My traffic is down considerably since I installed and unintsalled this plugin.

    I don’t think you need to hire anyone; some of the folks around here are quite knowledgeable of htaccess things. Do you have access to the file now? Is it still empty?

    It is not empty.

    it looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]

    # END WordPress

    I don’t see any problem with it, assuming your site is in the /blog/ directory.

    My site is in the blog directory.


    On the “options” page, my word press address (url) and my blog address (url) are both set as

    I don’t remember how they were set before I installed the plugin.

    My traffic has fallen of significantly since I installed and uninstalled and I don’t know if something is still wrong. I did lose maybe a week and a half of being spidered.




    aside from the fact that you are running a version of wordpress that needs to be upgraded due to publicly available exploits…

    Thank you. I just upgrading using the latest version my host has available. It is not the most current though.

    They won’t let you upgrade it yourself? Also, are you “pinging” Google when you post? I know googlebot’s aware of your site, but sometimes after a run-in with problems like you had it might be wary of visiting for a while. Throw out the welcome mat.

    Yes, I am pinging google.

    I could upgrade it myself, but it scares me. Googlebot is definitely back now but my traffic seems so much lower than it was before.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘I did something to stop the googlebot from coming back’ is closed to new replies.