Support » Plugin: Widgets on Pages » I definitely canceled autoupdates and am back to old version

  • Resolved jaroslawistok

    (@jaroslawistok)


    Till yesterday all was working well but I guess because of autoupdate now nothing worked anymore. While the idea with extra menu for Plugin and numbered sidebars is good it doesn’t work for me. I looked for php Version as in thread before, it’s 5.6.30.

    I just cant’t place a widget in the side bar. After Update it desappears again.Was happy to have the older version as File and have installed it again…

Viewing 15 replies - 1 through 15 (of 54 total)
  • Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Hi @jaroslawistok,

    Very sorry to hear this.
    Could you explain further what you mean by “can’t place a widget in the side bar”?
    Are you saying you can’t drag widgets into the sidebar?
    Or that they are not showing in your posts/pages?
    Do you have a link at all?
    Ta

    I drag the old one widget which was outsorted also put a new empty one and a filled out new one.
    In All cases I can drag them to the widgets sidebar 1 but after refreshing the site there are no more there.

    I remember activating a new one plugin was an error (something about expecting array or so) from bbpress, core functions.php like:

    // Noop if WP core supports this already
    if ( in_array( ‘post_parent__in’, $wp->private_query_vars ) )
    return $where;

    // Bail if no object passed
    if ( empty( $object ) )
    return $where;

    maybe it helps to find a reason. I understand not a lot from this ;o)

    • This reply was modified 2 years, 4 months ago by  jaroslawistok.
    • This reply was modified 2 years, 4 months ago by  jaroslawistok.
    • This reply was modified 2 years, 4 months ago by  jaroslawistok.

    Same here,
    Widgets disapear after refreshing the site.
    Wordpress 4.7.4 on PHP 5.2.4

    I’v deleted sidebars and created new ones,
    drag old widgets to sidebars => these dont appear on page.
    Made new Widgets, saved => new and old widgets appear.
    => refresh page = widgets are deleted from sidebars.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    At the mo we know there is a conflict with pre PHP 5.4 and the latest version of the plugin.
    You can downgrade to v0.0.12 here https://downloads.wordpress.org/plugin/widgets-on-pages.0.0.12.zip, or could you potentially update your PHP version?

    Sorry for the issue, I am working on a fix.

    As for the php-Version:
    Wordfence says 5.2.4
    Server-Info says 5.5.9
    Well…

    Thanks for the link to the old version and all your efforts!

    OK: Installed the old version = up and running.

    Thanks again
    and
    best regards
    Christian

    • This reply was modified 2 years, 4 months ago by  kech61.
    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Cheer Christian… this would explain it more for me, thanks.

    For info I have reverted the stable version back to 0.0.12 for now whilst I investigate and test a fix for the issue on older PHP versions.

    Again, so sorry for any inconvenience.
    Todd

    Hi @toddhalfpenny,

    same issue here with the new version.
    But Server Info shows PHP version 7.1.1-nmm1. So it seems not only to be a problem with older versions.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Thanks (and sorry) @upeuker.
    Maybe this is not a php issue.
    Could you possibly explain what happens in your scenario, and what WordPress version and theme you’re using?

    I use the Elmastudio Dorayaki Theme.

    The page is not yet published so the problem at the moment only was an issue for myself.

    The widget areas are all were wiped out and the widget were placed in the “unused” area.
    It was not possible to drag them back.

    After recreating the widgets they appeared on the page but back on the dashboard all areas again were wiped out.

    Reinstalling the 0.0.12 version has solved the issue.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Thanks @upeuker.

    I have “unresolved” this thread as it’s obviously still an issue.

    Could you try naming the Turbo Sidebar, before adding widgets to it, to see if perhaps it’s a conflict with the default naming?

    I not fully understand your request.
    The names of the Turbo Sidebars were not lost.

    I renamed one but dragging the “interactive widgets” back to the widget area does not work.

    The workaround in my case is now (with the version 1.0.4): creating new Turbo Sidebars and dragging back the “interactive widgets” to this areas.
    This seems to work and hopefully the widgets will stay on there place now 😉

    @toddhalfpenny: Thanks for your work

    Hi, I have the same behaviour as kech61, with PHP version: 5.6.30-0+deb8u1 since the 1.0.4 update

    old version works perfectly

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Thanks @upeuker for the update… this is indeed useful info, and so sorry that you had to re-configure the sidebars.

    @mischamole, are you able to try what @upeuker has done, and let me know if this also works for you?

    Thanks, Todd

    Did the same as @upeuker, and it works! 🙂

    However, theres a “new” problem: I’m also using the “Shortcode any widget” addon, and after the 1.04 update, the “li” list-style bullet is showing on this particular addon. Do you have any suggestion how to remove/hide that again 🙂

    (I’ve already activated your styles :))

    @toddhalfpenny: Thank you for a great plugin which I’ve been using for years.

    • This reply was modified 2 years, 4 months ago by  Optimator.
    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Hey @optimator, sorry to hear you’ve also seen this issue. I’m traveling at the moment but will try to investigate this week.
    As for the style issue, would you mind creating a new thread, and posting a link, if you have one?
    Thanks.

Viewing 15 replies - 1 through 15 (of 54 total)
  • The topic ‘I definitely canceled autoupdates and am back to old version’ is closed to new replies.