Support » Fixing WordPress » I changed my settings from to…

  • Resolved marialipani


    And now I am completely locked out of WordPress and my blog is nowhere to be found at either address. I am a complete newbie and this is freaking me out. Please help.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You will need to change it back.

    Changing The Site URL

    [edit] – use the phpMyAdmin method if available to you.

    I had found this thread earlier and tried the functions.php fix, but it didn’t work and now there is a different error message.

    Not sure I could handle using phpMyAdmin assuming I could find it. Is there something else you can suggest?

    Does this mean the entire blog is lost??

    No, it’s not lost. You just need to change the urls back in database. (assuming that is the only thing wrong at this point) If you don’t, the alternative is a reinstall. It really isn’t as bad as it looks on the surface if you have phpMyAdmin. It’s good to know how to do it. Check in your hosts control panel and see if that database tool is available to you.

    Here is a very easy tutorial for the phpMyAdmin method.

    As always, make backups before undertaking a new venture…

    Okay, thanks. I’m having trouble with the c-panel but have just sent a message to the host. Just one more question if you don’t mind…worst case if I had to reinstall, would that mean that I would lose everything?

    If you clear the database, yes. However; if you have been keeping regular database and file backups, you minimize the losses to the point of your last backup.

    Right now, your only issue (as far as we know) is just the change of address in the database. It really is much, much easier to pursue that repair than it would be to reinstall if you have no backups. Fixing that issue is really a very minor task.

    Best of luck to you.

    Restoring a backup is in my opinion a harder process then using phpmyadmin to update two fields in the options table, like Clayton said..

    If you’re happy enough to be restoring backups you certainly should be capable of using phpmyadmin.

    If necessary i’m sure myself, Clayton or another member can provide you with an SQL query you’d run from phpmyadmin that will in turn mean you literally only need to make about 4-5 clicks, and even then we can provide you with direction on what to click, it’s really not that tough…. once you get down to it… 🙂

    It’ll only ever be as hard as you want to make it.. 😉

    Thank you both so much. This is really anxiety provoking and I’m not out of the woods yet…So I was able to get find phpMyAdmin and to follow the tutorial posted by Clayton James. I then contacted the host and was able to confirm that the domain is now set without the www. BUT, it seems like I created a new error when I originally tried the quick fix method of modifying the functions.php. So, even after the phpAdmin changes there is a new error message that reads:

    Warning: require_once(TEMPLATEPATH/lib/classes/css.php) [function.require-once]: failed to open stream: No such file or directory in /home/mbali/public_html/functions.php on line 41

    So now I’m assuming that I somehow have to correct this functions.php file, but don’t know how. Can you help with this?

    I have no idea if I have backups.

    Something is still not right, there should not be a functions.php in either your site root or wordpress root folder, unless you specifically put one there for something non-wordpress.

    public_html is the folder you place your website content into (aka the root level folder), the path behind that is just part of the servers directory path to that folder..

    What exactly did you do prior to this error occuring in the first place?

    when i read the quick fix solution i immediately opened FTP and started looking for the functions.php folder. I found it but it was on the left hand side rather than the right hand side. Thinking that I needed it on the right hand side so that I could open and edit it I dragged it from the left to the right – pretty much following the same procedure that I used when I uploaded each of the WordPress plugins. I didn’t aim for any particular place – based on your comment, maybe it’s in the wrong place?? any help is incredibly appreciated…

    Usually left panel represents the local folder, and the right indicates the remote (website) folder, it doesn’t necessarily mean the folders are a direct relation to one another.

    Have you updated your WordPress url settings back to their original settings since starting the thread?..

    That is the first thing you need to do, as we’ve outlined above, which does not require that you move/copy/edit any core wordpress files.

    yes. i did that last night using the phpMyAdmin.

    Well i’m honestly at a loss to what the problem can be, if it worked before the URL change, and you’ve now changed that back, logic would dictate that it should have fixed the problem, don’t you agree?..

    Did you move or copy anything else at all?

    Can you provide a URL to the site? It would help a great deal, and i can edit the link out for you later if necessary..

    EDIT: Would this happen to be your site?

    Asterisked some of the characters incase you’re wanting to keep the URL private.

    Yes, that’s the site.

    Could it be that when i dragged the functions.php file to the right side i dropped it in the wordpress root folder? i’m not at home and so am not looking at it now, but maybe this is why the error message since as you’ve pointed out it’s not supposed to be there?

    also, remember that after i dragged the functions.php file over to the right side i also modified it using the method below. this is when i started getting the error message.

    update: i posted this problem on the thesis help forum too and it was suggested that i try this: replace completely your current function.php with a fresh, default copy from a download of WordPress. Have the replacement copy of functions.php ready to hand; delete the one that’s on your server, then upload the replacement in its spot. – do you agree that i should try this?

    Quick fix method
    If you have access to the site via FTP, then this method will help you quickly get a site back up and running, if you changed those values incorrectly.

    1. FTP to the site, and get a copy of the active theme’s functions.php file. You’re going to edit it in a simple text editor (like notepad) and upload it back to the site.

    2. Add these two lines to the file, immediately after the initial “<?php” line.

    Use your own URL instead of, obviously.

    3. Upload the file back to your site, in the same location. FileZilla offers a handy “edit file” function to do all of the above rapidly, if you can use that, do so.

    4. Load the login or admin page a couple of times. The site should come back up.

    5. Repeat the above steps, but remove those lines. IMPORTANT: Do NOT leave those lines in there. Remove them immediately after the site is up and running again.

    If there is no functions.php file in the theme: Create a new text file called “functions.php”. Edit it with notepad, and add this text to it, using your own URL instead of

    Upload that to your theme directory, then proceed as stated above. Remove the file afterwards.

    Well if the problem is with the theme, personally i’d suggest switching theme first to see if that resolves the main issue, if it does, then move onto fixing the broken theme.

    However you’ll not be able to do that without admin access…

    Perhaps the easiest option would be to replace the theme with a fresh copy, providing you’ve not made modifications to it (in which case make a copy of it before over-writing or deleting it)..

    Theme’s go into the /yourwordpressfolder/wp-content/themes/ folder, and not in the root..

    The above suggestions aren’t likely to help as long as you’re unable to render a page, by all means if replacing the functions file fixes that then the above advice should work fine, but i can’t see how you could apply the above suggestions without the ability to load any page (as it stands now)..

    Great news! I just got an e-mail from my host provider and the following worked. He says:

    I’ve removed the functions.php script that was in the public_html/ directory of your account, as this file already exists in the thesis_16/ themes directory.

    Thanks to all for the help with this!!!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘I changed my settings from to…’ is closed to new replies.