Support » How-To and Troubleshooting » I can't upload photos to media library any longer

I can't upload photos to media library any longer

  • I can no longer upload photos to my Media Library. It shows that it is uploading…the “bar” gets to 100%…then backs off a few points then goes into “crunching” which never stops. Can someone help? I am very new at this. I’m using a MacBook Pro and trying to upload from IPhoto.

Viewing 15 replies - 1 through 15 (of 15 total)
  • I think this might be cause by your browser or your connection.

    Did you try it with a different browser and/or did you try to clear your cache/cookies?
    If this does not help, try a different computer if available. If you have the same issue with another computer, it might be your connection that is not stable. Try to test it with a different ISP then.

    What version of wp and was it recently auto updated?

    It is version 3.8.1

    I just updated everything today. I have noticed as well today that older photos are uploading. I just cant’ seem to get the ones I took here in Morocco to upload. I thought maybe it was the camera…too many pixels or something but I was able to upload my pics from another country taken with same camera.

    When you go to insert an image in the post editor, do all images and available image sizes show up under the media library option?
    Can you upload images there?

    I’ll check right now, thanks!

    It will allow me to upload a photo to my post that is already in my Media Library. I just can’t seem to get my recent pics uploaded to the Library even one at a time. It gets stuck at “crunching” forever until I give up.

    I tried using another browser and it still does not work with the photos I took a few days ago.

    Take a look at this thread and see if the symptoms are similar.
    I experienced something like this in 1 or 2 sites after updating to 3.8.1 and the plug in from wp ranger seemed to do the trick. Do a full back up first though just in case.

    I checked out that thread.

    I don’t see a an area to size either but I have not got that far yet. My problem is: I can’t upload photos to my Media Library that I snapped in the last few days…I can upload all photos before a few days ago, however. I was in Puerto Rico a month ago and using the same camera. I’m in North Africa now using the same camera and the recent photos won’t upload. I don’t get it. I’m back in the States in less than two weeks. I’m not computer savvy enough to follow all the threads and will need some hands on help. I’m sorry to take up your time.

    best, Dan

    No problem. As Rasierer mentioned, if the variable is your location it could be something to do with the internet connection you’re using and not a WP problem at all.

    Well, I may not know much, but I don’t think it is the Internet connection. I’m watching movies on Netflix etc without a qualm. Also, I am able to upload other photos taken before this issue occurred a few days ago. So, I think I need a genius with infinite patience to help me! I have a guy in Mexico looking into it. It most likely is something I did inadvertently. I just don’t know enough to articulate it or remember…what I did…
    PS I just took a photo now and tried to upload…it goes into Iphoto but not in my Media Library. Really frustrating…

    I can upload what is in my Media Library to my post/blog as I tested it earlier today…just can’t add the pictures on to WordPress now for some reason

    i’m sure it’s not the location of the user – i’m using a local server – and i get the same error – i’m uainf ver 3.8.1 as well

    “uainf” = “using”



    I cannot upload images anymore. This is a new problem in the past week or so. I updated to newest version of wp, and still have the problem. The message is:Unable to create directory uploads/2014/09. Is its parent directory writable by the server?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘I can't upload photos to media library any longer’ is closed to new replies.