Support » Fixing WordPress » I can’t upgrade my website to the new 4.7.4

  • I cannot upgrade to the new 4.7.4. i keep getting the following message.

    Update WordPress

    Downloading update from https://downloads.wordpress.org/release/wordpress-4.7.4-new-bundled.zip…
    Warning: file_exists(): open_basedir restriction in effect. File(/var/www/domains/costumes-n-masks.com/tmp//wordpress-4.7.4-new-bundled-SR9uUd.tmp) is not within the allowed path(s): (/usr/libexec/php5-cgi/share/pear/:/usr/libexec/php4-cgi/share/pear/:/usr/local/pem/vhosts/171432/webspace/siteapps/:/usr/local/pem/vhosts/171432/tmp/) in /usr/local/pem/vhosts/171432/webspace/siteapps/WordPress-61138/htdocs/wp-includes/functions.php on line 2070 Warning: is_writable(): open_basedir restriction in effect. File(/var/www/domains/costumes-n-masks.com/tmp/) is not within the allowed path(s): (/usr/libexec/php5-cgi/share/pear/:/usr/libexec/php4-cgi/share/pear/:/usr/local/pem/vhosts/171432/webspace/siteapps/:/usr/local/pem/vhosts/171432/tmp/) in /usr/local/pem/vhosts/171432/webspace/siteapps/WordPress-61138/htdocs/wp-admin/includes/file.php on line 184 Warning: unlink(): open_basedir restriction in effect. File(/var/www/domains/costumes-n-masks.com/tmp/wordpress-4.7.4-new-bundled-SR9uUd.tmp) is not within the allowed path(s): (/usr/libexec/php5-cgi/share/pear/:/usr/libexec/php4-cgi/share/pear/:/usr/local/pem/vhosts/171432/webspace/siteapps/:/usr/local/pem/vhosts/171432/tmp/) in /usr/local/pem/vhosts/171432/webspace/siteapps/WordPress-61138/htdocs/wp-admin/includes/file.php on line 493

    Download failed.: Destination directory for file streaming does not exist or is not writable.

    Installation Failed

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator t-p

    (@t-p)

    If your server does not like automatic upgrading, then try MANUALLY updating. Download a fresh copy of the WordPress .zip file to your computer, unzip it, and use that to copy up all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory. You may need to delete the old wp-admin and wp-includes folders and files on your server before uploading the new ones. Please read the Manual Update directions first.

    Backup: If you haven’t already done, always backup everything (including your database) before doing any actions, just in case something really goes wrong. You can never have enough backups!

    Thread Starter portfood

    (@portfood)

    I will try that T-P but it hasn’t worked for me in the past. I don’t know why all the rest of my websites have been upgraded from WordPress and this one won’t.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘I can’t upgrade my website to the new 4.7.4’ is closed to new replies.