[resolved] I can't upgrade. (6 posts)

  1. actionflickchick
    Posted 5 years ago #

    I'm trying to upgrade http://filmgirlforce.com to the newest version but it won't let me. I get this message when I try. I have no idea what to do about it.

    Upgrade WordPress

    Downloading update from http://wordpress.org/wordpress-2.9.2.zip.

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2516357 bytes) in /home1/patchwo2/public_html/filmgirlforce/wp-includes/http.php on line 1327

  2. James Huff
    Volunteer Moderator
    Posted 5 years ago #

    Try one (or all) of these:

    1. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');
    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    4. Talk to your host.
  3. actionflickchick
    Posted 5 years ago #

    I did the first one. I need to look into items 2 & 3 now. I tried editing http.php since that's what the error message said, but here's what's on line 1327 and I don't see what it has to do with anything:

    $parts = explode("\r\n\r\n", $theResponse);

  4. actionflickchick
    Posted 5 years ago #

    Edited .htaccess, got this message when I went to home page and had to revert:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@filmgirlforce.patchworkminds.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

  5. actionflickchick
    Posted 5 years ago #

    And I can find no php.ini file for that domain.

  6. actionflickchick
    Posted 5 years ago #

    All I had to do was deactivate the plugins while doing the upgrade. It was that simple.

Topic Closed

This topic has been closed to new replies.

About this Topic