Support » Localhost Installs » I cant update my Permalinks without breaking everything

  • I have a Site that I am trying to add BuddyPress to. I have everything installed and ready to run, but I have a message that says I need to update my Permalinks to something other than Default for it to work. If I change the Permalink structure to something other than Plain, I get 404 errors on all of the pages except for my home page. Is there something I am doing wrong, or is there a good plugin that can help me with the issue?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • The problem is one of the following:

    1. Apache is not configured to support .htaccess files
    2. Apache is missing the rewrite module
    3. Your server is using nginx and not Apache
    4. Your server is using Windows IIS and not Apache

    Since you posted this in the localhost installs forum, my suggestion is to check the documentation for whatever system your installed (WAMP, MAMP, XAMPP, etc). If you posted in the wrong forum and this is a hosted server, then you should contact your hosting provider.

    Another option is to find an alternative to BuddyPress, one that doesn’t require changing the permalink setting.

    Thanks for the response. This is a self hosted website, and I am running Apache as the web server. I will look into the first 2 options and also look into other plugins to replace Bubbypress(This would probably be the easiest method).

    Hi, @kd7vea.

    Please, make sure mod_rewrite is enabled in your server.

    If you have access to Apache files in your server, you’ll have to locate the Apache httpd.conf file.

    Inside, locate the following line:

    #LoadModule rewrite_module modules/mod_rewrite.so

    You just need to remove the hash sign, so it looks like this:

    LoadModule rewrite_module modules/mod_rewrite.so

    You can also request your hosting company to do this for you.

    Hope that helps!

    Hi @kd7vea,

    The one solution that always worked for me is just open your .htaccess file and write this line Options +FollowSymLinks at the very beginning of the file(it should be the first line of your file) and it will fix your issue.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.