Support » Fixing WordPress » I can’t tag or edit the dates after the update

  • Resolved marcusbae

    (@marcusbae)


    Hello guys.

    After this new update, I’m not able to tag my posts, or edit the URL, the date of the post … NOTHING.

    I click on “edit” for example, and nothing happens. I click on add tags, and nothing happens. It is as if the button was not clickable.

    Does anyone know why this is happening and how to resolve it?

    Thanks.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi Marcus, thanks for posting here 🙂

    Are you seeing any errors in your browser’s JavaScript console? If so, can you copy/paste them here?

    Thread Starter marcusbae

    (@marcusbae)

    Some people told me to reinstall wordpress 5.6.

    I was going to do this to try to solve the problem, however, before I had clicked on “hide this update” which is next to “reinstall now”.

    So I am not able to reinstall wordpress in any way. Do you know how to help me have this reinstall button again?

    I’ve been looking for this for hours. Thanks.

    Thread Starter marcusbae

    (@marcusbae)

    I got it through a plugin, but the problem continues.

    Moderator Helen Hou-Sandi

    (@helen)

    Core Lead Developer and 4.0, 4.7, and 5.6 Release Lead

    @marcusbae Could you possibly post which editor you are using, your active theme, and any active plugins?

    And just to check, since you note you clicked the “hide this update” button, does this mean you are using a language other than US English for your WordPress dashboard?

    Are you seeing any errors in your browser’s JavaScript console? If so, can you copy/paste them here?

    We, too, were seeing this and by looking at the JavaScript console it was obvious that some non-existent functions were being called. I also noticed that it was loading all JavaScript from my browser’s cache/memory, and not from the site.

    To fix it, we forced our browser(s) to reload everything from the site.

    In Safari, hold down Option key while going to View > Reload Page from Origin.

    In Chrome, holding the Shift Key down and choosing View > Force Reload This Page did it.

    Finding the same problem. Using the Classic Editor and editing the date as well as setting Visibility, Status, and adding tags is all dead in the water.

    Like macobserver noted, I tried clearing my cache as well as force reloading the page and problem persists. Plain to see that some JS has been done away with that’s still being called on the page. Otherwise, all my sites work fine.

    Appears to be JQuery related as this comes up in the Console:

    jquery.min.js?ver=3.5.1:2 Uncaught TypeError: this._addClass is not a function
    at $.<computed>.<computed>._create (autocomplete.min.js?ver=1.12.1:9)
    at $.<computed>.<computed>._create (jquery-ui.js?ver=1.0:415)
    at $.<computed>.<computed>._createWidget (jquery-ui.js?ver=1.0:585)
    at new $.<computed>.<computed> (jquery-ui.js?ver=1.0:376)
    at HTMLInputElement.<anonymous> (jquery-ui.js?ver=1.0:531)
    at Function.each (jquery.min.js?ver=3.5.1:2)
    at s.fn.init.each (jquery.min.js?ver=3.5.1:2)
    at s.fn.init.$.fn.<computed> [as autocomplete] (jquery-ui.js?ver=1.0:523)
    at s.fn.init.u.fn.wpTagsSuggest (tags-suggest.min.js?ver=5.6:2)
    at HTMLInputElement.<anonymous> (tags-box.min.js?ver=5.6:2)

    Does that still happen if you temporarily disable all plugins, and switch to one of the default “Twenty” themes?

    If not, then re-activate the theme and plugins one-by-one, and tests for the error. That’ll let us know which theme/plugin is related to the problem.

    Already tried that. Still affected.

    Hmm, I haven’t been able to reproduce that, but one thing that seems off from that console log is this line:

    at s.fn.init.$.fn.<computed> [as autocomplete] (jquery-ui.js?ver=1.0:523)

    There is no jquery-ui.js file in Core, and the jQuery files it does have are at version 1.12.1, rather than 1.0.

    Can you open the Network tab, and get the full URL to that jquery-ui.js file, and post it here?

    hudin

    (@hudin)

    Many people have noted the same problems on the page for the Classic Editor plugin so it’s a large-scale problem.

    Thread Starter marcusbae

    (@marcusbae)

    My problem was with the Classic Editor plugin.

    When I uninstalled it, there was an error and I couldn’t do anything on the site anymore.

    I hired a programmer to try to find the problem. He did not succeed in any way, until the next he remembered that it could be Cloudflare.

    He asked me to clean the cloudflare cache. I did that and solved it.

    I don’t understand anything about this subject or the reasons why it happened. Does anyone know? I know this solved my problem, but I was concerned about the next updates.

    Ian Dunn

    (@iandunn)

    Ah, that makes sense. When someone loads your website, the request gets directed to Cloudflare first. If they have a copy of the requests page, then CF will respond to the request; if not it will direct the request to your web server.

    Cloudflare was responding to the request, but with an old copy of some files. I think some old jQuery files were removed from Core in 5.6, as part of the jQuery migration.

    If that’s the case, then I don’t think it will happen with the 5.7 update, since AFAIK there won’t be any more files removed.

    If it does, though, then clearing CF’s cache should fix it. That’s a good thing to do any time you’ve having a problem after an update. They also have a way for you to temporarily turn off caching, I think they call it “development mode” or something.

    Thread Starter marcusbae

    (@marcusbae)

    Thank you very much for your help and information, Ian Dunn.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.