WordPress.org

Support

Support » Plugins and Hacks » WP Facebook Open Graph protocol » [Resolved] I can't share links on facebook

[Resolved] I can't share links on facebook

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Chuck Reynolds

    @ryno267

    Well first off you need to put your personal ID into the admin field not the link to facebook graph with your page ID. Pages are not personal profiles. the FB Admins line needs your personal facebook ID – like the plugin descriptions says.

    Secondly you have another plugin adding OG: code.

    Fix those and the plugin works as intended.

    Thank you!!
    I changed my facebook ID and now one of the two links works, but not the other one, http://duevoltemamma.com/2014/06/13/mebby-scaldabiberon/ and neither http://duevoltemamma.com/2014/06/17/babyfood-portapappa-40settimane/ published a few minutes ago.
    I don’t have another plugin adding og:code!
    Thank you for your help!!! It’s very importanti for me!

    Plugin Author Chuck Reynolds

    @ryno267

    well now you have 3 plugins doing og: tags

    <!--/ Facebook Thumb Fixer Open Graph
    <!-- WordPress Facebook Open Graph protocol plugin
    <!-- START - Facebook Open Graph Meta Tags

    You also still have the full url in the admin ID box… Again… JUST THE ID. At least it looks like you did change the ID from the page. just do the number not the url to facebook.

    <meta property="fb:admins" content="http://graph.facebook.com/1442196904"/>

    SHOULD BE

    <meta property="fb:admins" content="1442196904"/>

    thanks!
    now I’de done all exactly in the admin’s field.
    I also deactivate and delete all others plugins.
    But links on facebook doesn’t work again: the debugger’s answer is always the same: “The ‘og:type’ property is required, but not present.”
    http://duevoltemamma.com/2014/06/17/40settimane-babyfood-portapappa/
    So what should I do??

    Plugin Author Chuck Reynolds

    @ryno267

    well you definitely have a meta tag IN your body content… and I highly doubt it’s my plugin doing it lol.

    <div id="main" role="main">
    <meta property="og:type" content="article" />
    <nav id="nav-single">

    I suggest turning off all plugins and test it one at a time to see which one throws it in there. Could be in your theme even? idk. Lot could be wrong.

    Just view-source. Search for “<meta” and see if that one still shows up in the body.

    Good luck.

    Finally I delete met tag manually from single.php.
    But now my links doesn’t still work!
    I have now published a new post, and while sharing, facebook returns me only website link.
    Any solutions?!??!?!
    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] I can't share links on facebook’ is closed to new replies.
Skip to toolbar