Support » Themes and Templates » I cant set my theme front page to static. I tried it all

  • Hi guys, I have change my theme to the static option for my home page and its still on post. also under my appearance tab my Theme Option tab wont work. I’m not new to wordpress so im not sure why it isnt working. I also changed it under the setting –> reading tab and the permalinks. Here is what the homepage is suppose to look like http://wordpress.smartaddons.com/themes/sw_go/

    here is what I keep getting
    http://www.thetyrahillshow.com/

    please help..
    also when I switch it to the twentyten theme it does the same thing no front static page

    [Moderator note: Please ensure you’re embedding links correctly into your posts]

Viewing 15 replies - 1 through 15 (of 23 total)
  • Hi Salaturation I didn’t attach anything, it was just the link to my site and what its suppose to look like.

    this is what its suppose to look like

    here is what I keep getting

    Have you tried deactivating ALL plugins and switching to twentythirteen theme?

    yes even when switch to another theme it still only recognize the post or comment page as the home page

    If you still need help with this, please post a link to your site with ALL plugins deactivated and twentythirteen theme active.

    Yes I do still need your help hon,

    here is the link to my site
    All plugins are deactivated and the twentythirteen theme actived

    Okay, so that shows a static front page.

    Yes, its so weird

    I’d suggest you ask the developers of the theme you are using about this – as it appears to be a theme issue.

    I thought that to at first but, its seem that know matter what theme i switch to i cant get the static home page

    As I posted above, on twentythirteen, your site IS showing a static home page.

    I have done all this hon, i have 7 wordpress websites. Your static home page shouldn’t have a comment box at the bottom. That should be your blog page. The static page should look like the template when you set the Home page to Static and the Blog page to Post.

    Your static home page shouldn’t have a comment box at the bottom.

    It does unless you turn the comments off – go to the pages screen, hover over QuickEdit and uncheck allow comments.

    On your site, in twentythirteen, look at the body tag in the output HTML – what shows up? It’s a page like this:

    <body class="home page page-id-40 page-parent page-template page-template-page-templatesfull-width-php logged-in admin-bar no-customize-support single-author">

    If it’s set to blog, it shows this:

    <body class="home blog logged-in admin-bar no-customize-support single-author">

    okay..This is what mines says when I view source page in html…

    <body class="home page page-template page-template-page-sidebar-php logged-in admin-bar no-customize-support">

    <body class=”blog logged-in admin-bar no-customize-support”>

    Yep, so the first one is a static page and the second one is a blog.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘I cant set my theme front page to static. I tried it all’ is closed to new replies.