Support » Fixing WordPress » I can’t ping or contact api.wordpress.org

  • Hello,

    I can’t ping or contact api.wordpress.org from my server.

    I can ping without any issues wordpress.org or any other address, it looks like my public IP address is in a range that has been banned from contacting the subdomain api.wordpress.org.

    Does anybody have any ideas about how to further troubleshoot this issue?

    Best

    Giorgio

    • This topic was modified 1 year, 1 month ago by Giorgio.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Tim Moore

    (@tmoorewp)

    api.wordpress.org redirects to the REST API Handbook: https://developer.wordpress.org/rest-api/

    What are your trying to accomplish?

    Thread Starter Giorgio

    (@superhub)

    I think the public IP address assigned to my server has been banned from WordPress from contacting api.wordpress.org. Do you know if there is a way to check this out?

    Maybe somebody with an IP address in the same block of mine did something wrong and WordPress banned all the IP addresses in the block.

    I cannot ping api.wordpress.org from these IP addresses: from 178.33.0.208 to 178.33.0.223

    Thanks for your help

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Ping isn’t really a good test. If you have CLI access from your server then try this curl command from their. Here’s what happens when I try that.

    
    $ curl https://api.wordpress.org/secret-key/1.1/salt/
    define('AUTH_KEY',         'quZT^:/@,rH+_GOmy|Aab2||(An<1!+nI#0E<[)-(E@+%=5e1E.wP*k iM}<L!PN');
    define('SECURE_AUTH_KEY',  'KDaA)rup-_eoR,V3eUhE3c&f-<.{re)n^_oUi$?j.WCT7HF|8C! ov+p)g^RSoG+');
    define('LOGGED_IN_KEY',    ',7Yu)[bI[p[_Rffjn>L+m[P@ChrZ5J#hoW;-NyW;l/|gk>-,wk+=|neM+=Ixf2oo');
    define('NONCE_KEY',        'uH!W-C]U^ TljM{.b8ielGw <cz=5+F3:476A4+rR]>Y:U$SOa%:Ww#B}Rn9O0#S');
    define('AUTH_SALT',        ',32e,-h&R3$JqK-!h1v5Xpnt,E(b@8AI5rwUs;t-,5qen]Jt6s/%..h|x+S71UGe');
    define('SECURE_AUTH_SALT', 'g?~rco$i?#3PHhiT*,o[n:Ac^)@g#M9=GWD6%DOL]|.{<+2]Hd}Dk0f^SI@bd?o:');
    define('LOGGED_IN_SALT',   '++}b#EK1v<-:8ni8Ob@gF?)uu*?_7f~W?B!+b1EIi!U-nY<x~tG4;rlH2cMTz5]n');
    define('NONCE_SALT',       'R>-V=O;hQpVLouSY@7]y[]9R9N+?zFoG04-MIICK>TQ$Tl-}G2^+{~Ecv]=GR?.!');
    
    $
    

    Which means everything is working. I can resolve that name to an IP, I can establish a TLS connection and I can ask for https://api.wordpress.org/secret-key/1.1/salt/ and get a reply.

    What do you get when you run that command? This command on the CLI.

    curl https://api.wordpress.org/secret-key/1.1/salt/

    AnDurugkar

    (@andurugkar)

    Just Put IP in hosts file
    198.143.164.251 api.wordpress.org

    • This reply was modified 1 year ago by AnDurugkar. Reason: adding tags

    Hi,

    I’m interested to fix also, because i’have same problem and so i think that i was banned too.
    if i try: curl https://api.wordpress.org/secret-key/1.1/salt/
    nothing happens for a long time and then appear a timeout message:
    curl: (7) Failed to connect to api.wordpress.org port 443: Connection timed out

    i’ve tried the same command in another server (same configuration,Os etc etc..)
    and i got right response like you told.

    placing row:

    198.143.164.251 api.wordpress.org

    in my hosts file
    worked! Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘I can’t ping or contact api.wordpress.org’ is closed to new replies.