Support » Plugin: Permalink Manager Lite » I can’t make the plugin work :-/

  • Resolved RadCon



    First, I have published ~500 pages. Their URL’s scheme is like that: https://domain.tld/page-slug/

    Then, I have organised my pages in parent and child-pages: parent page has one slug, then we have a sublevel with another slug and then the child-pages. So, I ended with this kind of URLs: https://domain.tld/parent-page-slug/child-page-slug/little-child-page-slug/, which is 1/ much too long, 2/ repeating the keyword too many times in the URLs.

    So, I installed your plugin to remove all the slugs which have been added to the pages URLs and get back to this scheme: https://domain.tld/little-child-page-slug/ without changing the hierarchy (parent/child/little-child) in WP’s back-end.

    WP Permalink Manager

    I tried different things but each time, it tells me nothing has been changed. What am I doing wrong?

    Thanks in advance for your help.

    Best regards,

Viewing 5 replies - 1 through 5 (of 5 total)
  • Of course, I tried to put this, in the field at the very top:








    And in the field below:


    Or nothing.

    No combination worked.

    Plugin Author Maciej Bis


    Hi @radcon

    it was impossible to “find & replace” it, because currently the plugin splits the URI into two parts (eg. parent-page-slug/child-page-slug/little-child-page-slug/):

    • base, eg. parent-page-slug/child-page-slug
      base & URI)
    • slug, eg. little-child-page-slug

    “Find and replace” process is done on them separately in “Full URI” mode. I am working on 1.0.2 version, where the issue will be fixed:
    parent-page-slug/child-page-slug/little-child-page-slug will be altered only once as a whole in “find and replace” process.

    1.0.2 version will be released today or tomorrow.

    Oh, excellent! It’s not everyday that I’m this lucky 🙂

    Thanks a lot, Maciej.

    Best regards,

    Plugin Author Maciej Bis


    Hi @radcon,

    the update is released, if you would like to get rid off parent’s slugs please use following settings:

    http://domain.tld/parent-page-slug/child-page-slug/little-child-page-slug/ (will work also with another “little child pages” with the same “base”).

    “Find …” field should be set to parent-page-slug/child-page-slug/.
    “Replace with …” field should be set to (empty value).

    Please let me know if it works or you need any further assistance.

    Best Regards,

    Hi Maciej,

    Absolutely perfect, I confirm it worked. Thank you very much!

    Best regards,

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘I can’t make the plugin work :-/’ is closed to new replies.