Support » Installation » I can’t log in, why?!?

I can’t log in, why?!?

  • For some reason, I can’t log into WordPress. I had my password changed through ‘Lost Password?’ but even when I entered the new one it still isn’t working. Why is this?

Viewing 15 replies - 1 through 15 (of 20 total)
  • I’m assuming that this is WP 1.2, which does have a problem with this.
    One solution for this is to edit the password field in the user table in the WP database, You’ll have to use phpMyAdmin or some other way to work directly on the database.
    You can ‘hash’ a new password, then overwrite the existing password in the database with the new hash. How do you encode your new password? Just visit http://bfl.rctek.com/tools/?tool=hasher where enter your desired password into the form, click the button, and out pops your encoded (hased) password. Replace the old hash in the database with the new one, and then login with your new password.

    Well I actually did the same thing that HTH suggested. You might find the whole solution vague, since HTH did not describe it fully. Well if you understand what he is saying, then its good. Else you can take a look at http://faq.wordpress.net/view.php?p=68
    Hope you sort everything out and get it running. I just started with it last night, and its a neat platform. Though it lacks some things compared to MT, but I love it for its simplicity and ease.
    All the best !!

    Tried a different browser ?

    Yes, with both IE and Firefox. I’ve also deleted my cookies and temp files in both cases. The result is the same.

    This is worth a look.
    Using phpmyadmin, you need to check that your url’s are correct inside the database.
    Open up phpmyadmin, click on the database name, and when you see the list of all the tables (like screenshot 3 here: http://www.mfr.f2s.com/phpmyadmin/ ) click on the ‘Search tab at the top.
    Put ‘scandal’ into the search box, and click ‘Go’
    The result should show that there were some results in the table ‘wp_options’
    Click ‘Browse’
    Now check that each of those items are correct.
    If they are not, click on ‘Edit’ (it’s the first icon in the row – looks like a pen and pad) and carefully correct that information.
    If that info is already correct, post back.

    I solved the problem. Following your instructions, in wp_options, the ‘siteurl’ is http://scandal.org/wordpress whereas the ‘home’ is http://scandal.org/weblog . I’m using a different blog and wp directory (it’s actually just a remapping of one dir to another to keep things clean).
    Following the instructions in this post I edited vars.php in the wp-includes directory, and am now able to log in successfully with either browser.
    Hopefully the devs are aware of the issue already as the fix was posted back in May. Thanks for your help, Podz.

    Glad it’s worked out 🙂

    I don’t understand what you are saying about this ‘hash’ business. Could you be more specific? Thanks a lot for all the help, I really appreciate it! ^__^

    Hash ?
    Just follow this link and you should be fine.

    Thank you so much Podz! I am going to link you on my website because you have replied two of my queries and helped me a lot! Thanks! ^___^

    I’m having the same problem, but only in Safari. I can log in with FireFox, Opera, or IE, but when I try to log in with Safari, it always bounces me back to the login screen with “wrong login/password”, which it also displays the first time in that screen before I enter anything. When I try to reset the password, it always shows the username as blank. I’m logging in as the administrator, which is the only user in ny blog.

    I was able to fix the login problem, which only occurred in Safari, by editing wp-login.php and changing every instance of COOKIEPATH to $COOKIEPATH in the setcookie calls.



    Volunteer Moderator

    Doesn’t HTH stand for Hope That Helps?

    Mr Moose ;),
    I don’t think it’s necessary to hash one’s password in phpmyadmin. If I’m not mistaken (and I might be!) you can simply select MD5 from the “function” drop-down and then put the new password in at the end as normal.
    It’s worked for me, anyway. Is this not the normal method?


    I had the same problem.
    This was wrong:
    table: wp_options
    record: siteurl
    field: option_value
    fix that and you might be ok

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘I can’t log in, why?!?’ is closed to new replies.