• Resolved maddcheddah

    (@maddcheddah)


    I keep getting this

    “Syndicating ****s… 0 posts were added”

    on every feed that I try to syndicate. Please help. Thanks.

Viewing 12 replies - 16 through 27 (of 27 total)
  • zzmaster

    (@zzmaster)

    yes, shutdown event isn’t fine for cronjobs, but we can tune it:

    set_option('syndicating_started_at', time());
    if (get_option('syndicating_started_at')+300<time())
      syndicate_again();

    why not?

    Plugin Contributor CyberSEO

    (@cyberseo)

    It works in a similar way via WP pseudo cron:

    wp_schedule_event(time(), csyn_get_cuctom_cron_interval_name(), 'update_by_wp_cron');

    The code you have mentioned above (the shutdown action) triggers by the server cron only (if “pull-feeds” magic number is given). It can’t be triggered by Google bot or something else, just because it doesn’t know the magic code, which is unique for every site. The only person who knows it is you.

    • This reply was modified 5 years ago by CyberSEO.
    RENTAVOTER

    (@texastaxpayer)

    Hi, I am having the same problem with v. 5.26
    I have it working in a test site on hostgator but when I installed it in the production site on godaddy it refuses to pull any feed. 0 … posts were added.

    thanks for your assistance in advance.
    AD

    https://news.google.com/news?cf=all&hl=en&pz=1&ned=us&q=Texas&output=rss
    https://drive.google.com/open?id=0B8kblcrgwfDgYjZrR253WDZpdTQ

    • This reply was modified 5 years ago by RENTAVOTER.
    RENTAVOTER

    (@texastaxpayer)

    Just notice this thread is marked as resolved. Should I begin a new one for my issue?

    • This reply was modified 5 years ago by RENTAVOTER.
    Plugin Contributor CyberSEO

    (@cyberseo)

    Your feed pulls just easily with the default settings. Everybody can check it. So I don’t see any issue. Please make sure that your host does meet the system requirements. Also check out the server logs.

    RENTAVOTER

    (@texastaxpayer)

    I appreciate your looking into this.

    I took the server requirements to godaddy customer support and they naturally said their server plan exceeds everything and it must me me or the plugin or not holding my mouth right. its just baffling why it wont work.

    thanks anyway

    Plugin Contributor CyberSEO

    (@cyberseo)

    Email me with an admin access to your WP control panel – I’ll take a look: cyberseo@cyberseo.net

    RENTAVOTER

    (@texastaxpayer)

    I just sent admin access.

    thanks

    RENTAVOTER

    (@texastaxpayer)

    Can anyone offer a suggestion on how I might diagnose the problem my self?

    • This reply was modified 5 years ago by RENTAVOTER.
    Plugin Contributor CyberSEO

    (@cyberseo)

    The plugin didn’t add new articles because you did tell it to “Do not syndicate post that doesn’t match at least one category defined above“. So every time when it tried to add a post, it checked if at least one of the post categories match yours (the categories defined in your blog). Since there was no matches, they were not added. That’s obvious, isn’t it?

    I’ve fixed your feed settings to “Create new categories defined in syndicating post” and the new posts are being added now. You may like to switch it to “Post to default WordPress category” is you wish so.

    RENTAVOTER

    (@texastaxpayer)

    I am extremely grateful to you for pointing out my error.It was not obvious to me. I knew to select my own WP category but the “undefined categories” is what tripped me up. However I do apologize for not catching on.

    Many thanks for a great plugin too.

    • This reply was modified 5 years ago by RENTAVOTER.
    • This reply was modified 5 years ago by RENTAVOTER.
    • This reply was modified 5 years ago by RENTAVOTER.
    Plugin Contributor CyberSEO

    (@cyberseo)

    You are welcome! And don’t forget to vote for the plugin 😉

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘I can’t get feeds to pull’ is closed to new replies.