Support » Plugin: Index WP MySQL For Speed » I cant find monitoring tab

  • I have installed the plugin ran the optimization tab and result was SUCCESS.
    I also uploaded metadata clicking the button. I have few queries;
    1. I cant find monitoring tab. please help to find and activate it
    2. I installed this plugin when I was getting ‘Database connection error’ whenever I work on wp-admin. I hope this plugin will help to resolve this issue. Our server is on DigitalOcean 4GM RAM 80GB space

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter healthcare nt sickcare

    (@vismithams)

    Metadata uploaded to id 4wtmwndu7a

    We have redis installed on our server and activated on this website. How your plugin compatible with Redis object cache and how both work together?

    Plugin Author OllieJones

    (@olliejones)

    Thanks for your feedback!

    I haven’t released the monitoring tab yet. It will appear soon in an update.

    This plugin will not help resolve your “database connection error” problem. That is very likely a problem with your MySQL server’s maximum number of connections. According to the metadata you uploaded, your max_connections value is 29,538. That is grotesquely misconfigured, and your MySQL server is probably running out of RAM. A value like 250 is much more common. See this.

    https://stackoverflow.com/questions/22297773/how-to-increase-mysql-connectionsmax-connections

    Your innodb_buffer_size is 2,147,483,648 (2GiB). It probably should be a bit larger; 70% of available RAM is generally a good setting. I suggest you review all your MySQL server settings.

    I have tested this plugin with the redis object cache. It works well. It only affects MySQL queries. And, the point of the redis object cache is to reduce the number of those queries.

    • This reply was modified 1 month, 2 weeks ago by OllieJones.
    • This reply was modified 1 month, 2 weeks ago by OllieJones.
    Thread Starter healthcare nt sickcare

    (@vismithams)

    Thanks for your support.
    Maximum number of connection on our server settings was 300 and I changed it to 250.
    Buffer size was default but I set that to 2800 (70% of 4gb ram)

    I really wonder how max_connections value was 29,538 when it was 300 in server settings.

    Plugin Author OllieJones

    (@olliejones)

    The pt-variable-advisor tool in the Percona Toolkit is a good way to check your MySQL server’s settings. It can help you find other possible issues. https://www.percona.com/doc/percona-toolkit/LATEST/pt-variable-advisor.html

    Thread Starter healthcare nt sickcare

    (@vismithams)

    I am none techie and have to depend on cloudeays support. Let me interact with them tomorrow and share the metadata once again to you.
    Can you advise how much should be ‘Lock wait timeout’ and ‘wait timeout’ values? These setting showing as ‘default’

    Plugin Author OllieJones

    (@olliejones)

    I would not change those two settings from the default.

    And, version 1.3.3 with the monitoring tab is now released.

    Thread Starter healthcare nt sickcare

    (@vismithams)

    Hello @olliejones
    Please read the support response from cloudways team;
    and after then new settings, metadata id is this;
    Metadata uploaded to id twARReKfYq
    ——————————————————————-
    Hope you are doing well. The issue seems to be due to a higher number of admin-ajax calls as found on your server for application:

    ueejsefrvt

    2885 8.28.82.71 /wp-admin/admin-ajax.php
    98 143.244.134.133 /
    66 8.28.82.71 /wp-content/plugins/webpushr-web-push-notifications/sdk_files/webpushr-sw.js.php
    36 143.244.134.133 /wp-admin/admin-ajax.php
    30 161.35.200.90 /

    These ajax calls are something that pushes changes you do in your website backend to the site, with the fact that you are experiencing it when you are working on your site clearly indicates that your server is overwhelmed with them therefore we need to increase the interval between these ajax calls on every site you are actively working on.

    Here is a detailed guide on how to overcome admin-ajax calls consuming your server resources. I can tell you briefly what is being done here that you can install a plugin termed HeartBeat Control separately and then modify the activity for the WordPress dashboard only to a value in between 200 and 300 secs.
    https://www.cloudways.com/blog/reduce-admin-ajax-php-related-server-load-wordpress

    As for the MYSQL settings, our default stack has been deployed after testing. Therefore, I would highly recommend you to first consult with us before changing MYSQL settings as it will only create new issues rather than mitigating previous ones. The official document states that the value for innodb_buffer_pool_size CAN be increase to 80% however this is a possibility, not a recommendation and this differs from host to host.

    You can test these settings as they have taken effect as of now and if you wish to reset them for you, we will be happy to do so.

    Plugin Author OllieJones

    (@olliejones)

    In general, I agree with your Cloudways team: Horsing around with MySQL settings is something you should do carefully and sparingly, especially on a server provided by a competent team.

    From their message, it looks like this plugin https://wordpress.org/plugins/webpushr-web-push-notifications/ is causing a lot of your server overload. But that’s hard to tell for sure. You could try disabling it for a few minutes to see whether things get better.

    Run a monitor with my new plugin version, or use the Query Monitor plugin to try to find out more.

    • This reply was modified 1 month, 2 weeks ago by OllieJones.
    Thread Starter healthcare nt sickcare

    (@vismithams)

    Thank you @olliejones
    Have you checked Metadata uploaded to id twARReKfYq ?
    I have installed Perfmatters plugin and enabled heartbeat on it

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.