WordPress.org

Forums

I Can't Enable Comments On Blog Posts (8 posts)

  1. Chris Thomas
    Member
    Posted 3 years ago #

    I have just published my first POST on my new (approx 27 PAGE)site
    but clicking on 'Please Leave A Comment' takes the user
    nowhere.

    qlanguage.com.hk/blog

    * I'm using the Headway Theme
    * In WP Discussion setting, I HAVE enabled comments
    * I have only published one blog POST and in 'Quick Edit'
    comments ARE enabled
    * I deleted the standard 'Hello World' first blog post, which
    DID have comments enabled AND all the 'entry boxes'
    (i.e.Email, Name Type your comment here etc.)WERE visible, unlike
    my first POST found at the link above

    Any help to resolve this will be greatly appreciated.

    Thanks

  2. Will Tait
    Member
    Posted 3 years ago #

    Similar problem:
    I am using WPFolio, have set up static home page and blog as in the WP codex. Comments function enabled and are showing up everywhere I expect to see them except on the blog posts.

    any insights or assistance greatly appreciated.

    Thank you.

  3. Chris Thomas
    Member
    Posted 3 years ago #

    Will,

    I have resolved my issue but I'm not sure it will help you.

    The one thing I'd failed to do was uncheck the 'hide comments'
    in the Content 'Leaf' of the blog index.

    If you are not familiar with Headway, Headway Leafs give you control over the visual placement and dimensions of page content. There is also (as I have recently discover) the ability to show or hide comments on individual leafs.

    I've no idea about WPFolio but 'maybe' there is a similar function?

    If you've not managed to sort it yet, I wish you all the best with it as I know too well how frustrating it is!

    Good luck!

  4. Will Tait
    Member
    Posted 3 years ago #

    Thank you,

    I do have all the relevant attributes activated. The weird thing is that within the WP dashboard the comments box shows up fine for each post and functions as it should, but when I bring up my website like any person on the web it doesn't show up.

    Regards,

    Will

  5. Chris Thomas
    Member
    Posted 3 years ago #

    Wish I could help you out but I can't.

    I'm sure and I hope you'll manage to get it sorted sooner or later.

    If for some reason you don't, you could consider what I was going to do (and actually still probably will anyway).

    You could integrate your blog with Facebook (and Twitter) using http://www.livefyre.com/.

    I have it on good authority that this is the best way to integrate Facebook comments (oppoesed to other plugins) as you keep ownership of all the comments on your own datebase.

    Quote from Nakeva (Head of Community at Livefyre),

    ........... we write all comments back to the WordPress database so you own the data, and we have deep integration with Facebook and Twitter. We are all about giving your users more options for commenting while giving you total control of the conversation.

    Again, good luck!

  6. Will Tait
    Member
    Posted 3 years ago #

    Thanks,

    I need to focus on the problem and not get sidetracked.

  7. Will Tait
    Member
    Posted 3 years ago #

    Resolved

  8. William van Nostrand
    Member
    Posted 3 years ago #

    I'm having problems as well. I am using a custom theme, but I tried changing back to Twenty-Eleven just to be sure it wasn't my theme causing the problems.

    The comment box was present yesterday, but today, for some reason, when I go to "quick edit," all the boxes seem to have been unchecked. I never disabled comments, so this is quite strange.

Topic Closed

This topic has been closed to new replies.

About this Topic