Support » Plugin: Posts in Page » I can’t edit, neither preview the posts page.

  • Hi, everybody!
    I have a problem with the posts page. I can’t edit it and I can’t make a preview. It leads to the home page. After changing the post page in settings and live it to “select”, the problem is solved. But I want the post to go to this page – blog page and would be good to add some widget too. I’ve made a new page, all the same. I deactivated the plugins, changed the theme, but also without any result.
    I’ll be very gratefull if somebody can tell me what to do.
    Thank you!

    • This topic was modified 6 months, 3 weeks ago by ina13.
    • This topic was modified 6 months, 3 weeks ago by ina13.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Eric Amundson


    Hi @ina13

    I’m afraid I’m not quite understanding so maybe I can ask some questions to clarify the issue. It’s unclear to me if you’re having a problem with the plugin or with what you expect to see on your Blog page.

    1. Are you using Posts in Page for the first time or have you been using it and then it stopped working for you?
    2. Under Settings > Reading, what do you have set for “Your homepage displays?”
    3. Can you describe exactly what you’re trying to do along with steps to reproduce the issue?
    4. Is your Blog an actual page?
    5. Do you have a static homepage (rather than a listing of posts)?


    Hi, Eric!
    Thank you for taking the time to write me.

    The website is quite new, less than a month. I have just one post and I don’t have problems with editing the post or posting it. I don’t have problems with any plugin either. I’ve deactivated all of them.
    The problem is with the page which is connected with the posts (in my case this page is the blog-page). The last big update, was the upgrade of WordPress – 5.4 version. Probably that’s the reason of my issue.

    I’ll answer the questions:
    1.I have been using the page and it stopped working for me after the upgrade.

    2.Under Settings > Reading > Home page is “HOME” > Posts page is “BLOG”.

    3.That’s what I want is to be able to edit the “BLOG” page. When I open the page, it is empty. Just the headline. The post is going there, because when the page is published I can see it, but when I want to put a widget on the page – for example – categories, a list with posts, search etc, after ‘save’ they don’t appear. I can’t design the page with a plugin too. When I want to preview the page, it leads me to the “HOME” page. After “save” any changes can’t be seen.
    When I go to Settings > Reading > Posts page and change the page from “BLOG” to “Select”, I can make the edit on this page and I can preview the edition.
    When I go to Settings > Reading > Posts page and change the page from “BLOG” to “ABOUT US”, I can’t edit, nor preview the “ABOUT US” page.

    4. The “BLOG” page is an actual page, a menu page.

    5. I have a static homepage.

    I really hope I’ve been able to explain.
    Thank you one more time!

    Plugin Author Eric Amundson


    Howdy @ina13 – Thanks for the answers.

    I think this article might have some answers for you.

    In short, when you set static pages for the Front page and Posts page in WordPress, the page you choose for the Posts page is really more of a stub or placeholder than an actual page you can edit.

    There are ways to display content on that page but by default, it’ll just show your latest posts in reverse-chronological order.

    Posts Page: (if not already created) create an empty page. Give it a Title that will be used on top of your posts list. This step is mandatory as you are modifying WordPress default setting. Any other content other than Title will no be diplayed at all on this specific page.

    Are you actually using the Posts in Page plugin or just wanting your posts to show up on the page you named Blog?

    Hi, Eric!

    Great article! Now it became clear to me. I was sure it was a bug and I did’t search for information about a static page.

    Thank you, it was very helpfull for me. 🙂
    Have a great Easter!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘I can’t edit, neither preview the posts page.’ is closed to new replies.