WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] I cant delete my default home page

[Resolved] I cant delete my default home page

  • I am setting up wordpress as a website and I constructed my first page as my home page but when I go to view my site I have 2 home pages and I can only edit and delete the one that I made ,how do I delete the default home page?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Eh? Did you make an html homepage called index.html and then started to work with WordPress or what is the situation?

    No Roy,I just logged into wordpress created a page and titled it home and when I wbnt to review I had 2 home pages and I cant figure out how to delete or edit the first,it does not show up on my dashboard pages when I go to edit the other pages all I get is my second home page and a contact page that I created.

    After creating your page, look under the Dashboard menu, select Reading and the first option you see is Front Page Displays. Choose the radio button called Static Page and there will be a drop-down menu showing all of the pages you’ve created. Select the one you made called Home. The default one should no longer appear. If this doesn’t work, please indicate which theme you are using and we’ll go from there. Good luck!

    I think you mean that you have two words “home” in the top navigation? One is probably hardcoded and always links to the page that you set as index (settings->reading), the other is added because you created a page called “home”. When you change the name of the page to something else, you will probably have a link “home” and a link “something else”. To remove the “home” link, you probably need to edit the header.php (themes->editor search header.php).

    Thanks Roy and thanks dmlennon
    Really appreciate your help dmlennon you were correct in the resetting the reading portion of my dashboard once I did that the default home page disappeared.Thank you much!

    No problem, glad to help! Most of the time this works. If you use themes and you come across one that uses a different template for the homepage – sometimes this solution will not work. I’ve had to go into the files and remove or rename the template file called frontpage (or whatever they’ve named it) and then the regular solution works. Good luck Rob.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] I cant delete my default home page’ is closed to new replies.
Skip to toolbar