Support » Fixing WordPress » I can't create or edit posts

  • I use WordPress 3.3 and Google Chrome 16.0.912.63 beta-m.

    CREATING a new post:
    Everytime I add a new post it just goes straight into a blank page with a url like:

    EDITING a post:
    Everytime I edit a post and click ‘update’, it directs me straight into a blank page:

    I have tried to re-upload files ‘post.php’ and ‘post-new.php’.
    I have tried to clear my cache.
    I have tried to google/surf the net for the solution. I couldn’t find one that works for me.

    NONE of all the above works.

    If anyone else has any solution for this problem please do help me!

Viewing 8 replies - 1 through 8 (of 8 total)
  • I had the same exact thing recently, anything I tried to add or update would fail and return a white page, no error message. Updates on template files would apply, but still return the blank page and I had to use the back button to get back to the site.

    I switched to my default theme and back and it fixed it. But I had to rename all my theme folders except the default twentyten to force wordpress to do it, as the white page would mess up my attempts to switch themes through admin settings!

    @deepbevel, sorry I don’t quite get the last paragraph of your response. Did you end up fixing it? What did you do?

    As I said, I renamed all my theme folders, including my problem theme, except twentyten. It forced WP to use twentyten. then I put the correct name back on my problem theme, re-activated it, and the problem was gone. But if you can switch themes through admin settings you won’t need to go on your server and rename your theme folders like I did. And I don’t know it will fix it like it did for me, but it’s the same symptoms.

    @deepbevel, I tried it but no, it didn’t work. It DID work when I put my theme back to default (twentyten). I was able to create and edit new post when I had the default theme. Thanks for sharing, anyway 🙂

    What I reckon is, it’s something to do with my current theme (not the Twentyten default theme). I was doing some editing with the files before and something I edited must have triggered the error. Only if I knew what it was 🙁 For now, I’ll just put the default theme back and add/edit posts then put my own theme once I’m done.

    Anyone else care to share their own solution to this problem? Any ideas what it might be?

    Looks like it’s time to inquire with the theme author. What theme is it?

    @deepbevel, The theme was Arthemia 1.0 by Michael Jubel Hutagalung

    You should probably save your modded theme, (if it has any mods to save) then reinstall a new version of it. Then go and put back your modded files one by one and narrow down what went wrong.

    @deepbevel, Thanks for the suggestion and helping me with this problem. I really appreciate it! Although, I did figured out my own solution and it was by clearing your browser’s cookies (not all of your browser’s cookies, just the ones with your domain).

    I don’t know if this solution works for anyone else but it worked for me.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘I can't create or edit posts’ is closed to new replies.