Support » Plugin: Site Kit by Google » I can’t connect to Google Site Kit

  • Resolved Tomek Zuk

    (@skarabeusz)


    I’m trying to configure the Site Kit.
    I am successfully passing the verification process.
    I allow Site Kit to access my Google account.
    I receive confirmation:
    You successfully set up Site Kit. You can now see how your site appears in Search, how many visitors you got from Search, your popular pages, and how people found them from Search.
    I go to Dashboard and see again:
    Sign in with Google to configure Site Kit.
    I tried with all other plugins turned off.
    I uninstalled and reinstalled the Site Kit.

    Please help.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    @skarabeusz Sorry to hear you’ve been unable to setup Site Kit successfully. There are some steps on the plugins website which may assist.

    If you’ve already attempted those steps can you please share your Site Health info with Site Kit installed and we can see if there’s anything we can identify which may be impacting setup in your case?

    
    ### wp-core ###
    
    version: 5.3.2
    site_language: pl_PL
    user_language: pl_PL
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/agro1/public_html/agrosalix.pl
    wordpress_size: 52,49 MB (55034814 bytes)
    uploads_path: /home/agro1/public_html/agrosalix.pl/wp-content/uploads
    uploads_size: 13,92 MB (14599830 bytes)
    themes_path: /home/agro1/public_html/agrosalix.pl/wp-content/themes
    themes_size: 4,35 MB (4564054 bytes)
    plugins_path: /home/agro1/public_html/agrosalix.pl/wp-content/plugins
    plugins_size: 66,68 MB (69916712 bytes)
    database_size: 7,68 MB (8053580 bytes)
    total_size: 145,12 MB (152168990 bytes)
    
    ### wp-active-theme ###
    
    name: Layers for Elementor (layers-elementor)
    version: 1.0.2
    author: Elementor
    author_website: https://www.layerswp.com/
    parent_theme: none
    theme_features: html5, title-tag, widget-customizer, woocommerce, post-thumbnails, custom-logo, automatic-feed-links, menus, customize-selective-refresh-widgets, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets
    theme_path: /home/agro1/public_html/agrosalix.pl/wp-content/themes/layers-elementor
    
    ### wp-mu-plugins (1) ###
    
    installatron_hide_status_test.php: author: (undefined), version: (undefined)
    
    ### wp-plugins-active (10) ###
    
    Elementor: version: 2.9.7, author: Elementor.com
    Elementor Pro: version: 2.9.2, author: Elementor.com
    Limit Login Attempts Reloaded: version: 2.10.1, author: WPChef
    Lingotek Translation: version: 1.4.6, author: Lingotek and Frédéric Demarle
    Polylang: version: 2.6.10, author: WP SYNTEX
    Polylang Connect for Elementor: version: 1.0.0, author: David Decker - DECKERWEB
    Rank Math SEO: version: 1.0.41.1, author: Rank Math
    Site Kit by Google: version: 1.6.0, author: Google
    Sticky Header Effects for Elementor: version: 1.3.2, author: Rwattner
    Wordfence Security: version: 7.4.6, author: Wordfence
    
    ### wp-plugins-inactive (1) ###
    
    Essential Addons for Elementor: version: 3.9.1, author: WPDeveloper
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Niedostępne
    imagemagick_version: Niedostępne
    gd_version: 2.2.5
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-962.3.2.lve1.5.26.3.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.3 64bit
    php_sapi: litespeed
    max_input_variables: 5000
    time_limit: 60
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 2M
    php_post_max_size: 8M
    curl_version: 7.62.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.29-cll-lve
    client_version: 5.7.29
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/agro1/public_html/agrosalix.pl/wp-content
    WP_PLUGIN_DIR: /home/agro1/public_html/agrosalix.pl/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### google-site-kit ###
    
    version: 1.6.0
    php_version: 7.4.3
    wp_version: 5.3.2
    reference_url: https://agrosalix.pl
    amp_mode: no
    site_status: connected-site
    user_status: not authenticated
    active_modules: site-verification, search-console
    required_scopes: 
    	openid: ⭕
    	https://www.googleapis.com/auth/userinfo.profile: ⭕
    	https://www.googleapis.com/auth/userinfo.email: ⭕
    	https://www.googleapis.com/auth/siteverification: ⭕
    	https://www.googleapis.com/auth/webmasters: ⭕
    search_console_property: none
    
    
    Plugin Support James Osborne

    (@jamesosborne)

    @skarabeusz Thanks for providing an update. While we investigate this further can you inform me of the following:
    – Were you able to connect successfully to Site Kit previously, using an older version of the plugin?
    – When you tried deleting and installing the plugin once more did you try installing from a Chrome browser incognito window?

    1. I have never succeeded on this page. Works on other my pages with similar configuration.
    2. Yes, I tried.
    I also tried with the Twenty Twenty theme enabled.
    The same every time: Congratulations! Welcome to Site Kit! Let’s get you set up.

    Hi @skarabeusz thanks for reporting this issue. We are working on debugging this issue.

    * Had you previously tried to connect this site to Site Kit?

    I have been trying since January this year

    @skarabeusz thanks for clarifying, this could help explain why your site remains stuck in a setup loop. I’ll see if there is anything to reset on the service end. Can you try the following please:

    * Disable Site Kit, and delete it from the WordPress plugin screen (this ensures all existing settings are removed)
    * re-install the plugin and try going thru the setup flow again.

    Let me know if anything has changed.

    I did.
    I get a message: invalid parameter: ‘client_id’

    @skarabeusz Thanks for taking the time to try to debug this! I have one more idea:

    I am seeing a mismatch between our service record of your site as “http://{domain name}” while your actual site uses a secure “https://{domain name}” URL. Is it possible you changed the URL (switching to https) of your site since starting the setup process?

    Can you please try this:
    * Under Settings->General change your site URL from https to http, click save. Change the url back again from http to https. Changing your site URL (and saving) will send an update to our service and fix the mismatch.
    * In site kit, click “Reset Site Kit” on the setup screen, then try the setup flow again.

    Nothing has changed.

    Had the same problem, fixed this by following instructions from another user with this problem: “I fixed it by going to my Google’s connected services (https://myaccount.google.com/permissions) > removing permissions > redoing the whole process.”

    Plugin Support Renee Johnson

    (@reneesoffice)

    @skarabeusz thanks for the follow up! We’ll continue to look into this and follow up on your topic.

    @boei thanks also for sharing! It has helped in some cases, so it could be a helpful workaround. We’re also looking into the correlation there.

    Plugin Support Renee Johnson

    (@reneesoffice)

    @skarabeusz I’m following up as we’ve just released version 1.7.0. It seems you you have updated to this version. Does the issue persist for you?

    If you’d like to attempt @boei’s suggestion for your case, that might be helpful to check. Note that this may remove Site Kit’s access to other sites, so you’ll need to setup those sites again.

    Yes. I just tried and succeeded. Thank you for your help.

    Plugin Support Renee Johnson

    (@reneesoffice)

    @skarabeusz thanks for the report back. Happy to hear it is resolved.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘I can’t connect to Google Site Kit’ is closed to new replies.