Support » Plugin: Images to WebP » I can’t activate it

  • Hi, I have temporarily disabled your plugin to detect a generic error on my site.
    Now I can’t activate it anymore. I have this error message:

    Add the following to your .htaccess file in /home/mywebsiteABC.com/public_html/ above the line reading # BEGIN WordPress, then try activate Images to WebP again:
    
    # BEGIN Images to WebP
    <IfModule mod_mime.c>
    AddType image/webp .webp
    </IfModule>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_ACCEPT} image/webp
    RewriteCond %{REQUEST_FILENAME} "/wp-content/"
    RewriteCond %{REQUEST_FILENAME} "\.(jpg|jpeg|gif|png)$"
    RewriteCond %{REQUEST_FILENAME}\.webp -f
    RewriteRule ^(.+)$ $1\.webp [NC,T=image/webp,E=webp,L]
    </IfModule>
    # END Images to WebP

    That code is contained in my .htaccess, above Begin WordPress.
    Why does this happen?
    Thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author kubiq

    (@kubiq)

    Hello,
    well, first of all, make sure that these lines are in your .htaccess

    Is it there?

    If not, then probably your .htaccess file is not writable anymore
    Maybe your server was updated and you have new PHP version with missing GD or Imagick library with WebP support?
    No idea, it can be many things, but firstly do what is written there 😉

    If it will not work, then you will need to contact your hosting/server provider, because they changed something probably.

    Thread Starter marcorroma

    (@marcorroma)

    Hi. Sorry for delay.
    The .htaccess file is writable by the user who is authorized to modify all the files of the wordpress installation. File permissions: 644.

    I checked if Imagick is installed. It works properly.
    Screenshot:
    https://i.ibb.co/5hTCfGh/imagick.png

    I await your support.
    Thank you

    Plugin Author kubiq

    (@kubiq)

    Hi,
    you didn’t answer whether your .htaccess contains these lines
    if yes and if this is state of your imagick library, then everything should work

    maybe it’s conflict with some other plugin, but it will be the first time

    or maybe there is some PHP problem, that you can find in your debug.log that stops image conversion

    or many other possible problems, but i’m not able to help you more in this theoretical discussion

    you can create thread on my forum support.kubiq.sk and there we can discuss your specific problem

    Thread Starter marcorroma

    (@marcorroma)

    Hi, I have the same problem on a test site.
    By disabling the “Complianz | GDPR / CCPA Cookie Consent” plugin, I can activate your plugin.
    Can you check this?
    Thank you

    Edit. it seems that multiple plugins are conflicting.
    I also found a plugin that prevents images from being uploaded if they are too small in width or height.
    And it seems to conflict with another plugin as well, I haven’t found it at the moment.

    • This reply was modified 4 months, 4 weeks ago by marcorroma.
    Thread Starter marcorroma

    (@marcorroma)

    On the test site: I tried to re-enable all plugins one at a time, and now it seems to work. Even if I try to activate your plugin last.
    I don’t understand what problem is interfering with the plugin.
    Is very strange

    Plugin Author kubiq

    (@kubiq)

    well, that’s really weird, but I’m glad it works now 😉

    Thread Starter marcorroma

    (@marcorroma)

    It works on the test site. But I can’t figure out which plugin it conflicts with

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    @kubiq It looks like you’re asking for access to a user’s site.

    While I know you have the best of intentions, it’s forum policy that you not ask users for admin or server access. Users on the forums aren’t your customers, they’re your open source collaborators, and requesting that kind of access can put you and them at high risk.

    If they are paying customers (such as people who bought a premium service/product from you) then by all means, direct them to your official customer support system. But in all other cases, you need to help them here on the forums.

    Thankfully are other ways to get information you need:

    You get the idea.

    We know volunteer support is not easy, and this guideline can feel needlessly restrictive. It’s actually there to protect you as much as end users. Should their site be hacked or have any issues after you accessed it, you could be held legally liable for damages. In addition, it’s difficult for end users to know the difference between helpful developers and people with malicious intentions. Because of that, we rely on plugin developers and long-standing volunteers (like you) to help us and uphold this particular guideline.

    When you help users here and in public, you also help the next person with the same problem. They’ll be able to read the debugging and solution and educate themselves.

    Thread Starter marcorroma

    (@marcorroma)

    I have tried on a test site and I have the same problem. Only if I deactivate all plugins can I activate “Images to WebP”. But I can’t disable all plugins on my online site. I deactivated all but one (for the order of the posts, which if I deactivate it I lose all the data of the order of the posts) but I cannot activate your plugin.

    After updating to the latest wordpress version I have one more error (below), screenshot:
    https://i.ibb.co/n6s4BYp/error.png

    Plugin Author kubiq

    (@kubiq)

    Hi,

    I’m not able to replicate your problem, so I can not solve something that I can not see.

    Please give me instructions or configuration files for any localhost software that I can install in exactly same way as you so where I can replicate this issue.

    For testing I was using Local by Flywheel and Xampp and many live servers all over the world and there was no problem, so I’m really curious.

    Plugin Author kubiq

    (@kubiq)

    Can you test this version please?
    https://files.kubiq.sk/images-to-webp.zip

    Also try to open /wp-content/plugins/images-to-webp/tests/test.png and let me see if you can see small solid color square or 4 squares with red dot in the middle.

    Thread Starter marcorroma

    (@marcorroma)

    Hi, I re-open this thread.
    It appears your plugin cannot write to the .htaccess file. But the tuoplugin code is included in the .htaccess file.
    In my opinion it's a problem with Cyberpanel (which I use, with Openlitespeed), which handles the .htaccess file.
    
    It is not a permissions issue with the .htaccess file
    • This reply was modified 2 months ago by marcorroma.
    Plugin Author kubiq

    (@kubiq)

    Can you try to deactivate and activate it again?
    Or you’re not able to activate it at all?
    Was it working and now it’s not?

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.